The forum

Tachyon: The Fringe

Author Replies
HittingSmoke Thursday 9 January 2014 at 0:13

WineHQ lists this as gold for WINE v1.1.14 but I'm having zero luck running it.

At first I was getting an a3dapi.dll error so I disabled it through WINE config. I still get the same crash though trying to load the game. Here is the debug output:

[01/08/14 15:04:41] - Running wine-1.1.14 Tachyon.exe (Working directory : /home/chris/.PlayOnLinux/wineprefix/Tachyon/drive_c/Program Files/NovaLogic/Tachyon)
wine: could not load L"C:\\windows\\system32\\plugplay.exe": Module not found
wine: Unhandled page fault on read access to 0xd5d11eda at address 0x40d772 (thread 0029), starting debugger...
Unhandled exception: page fault on read access to 0xd5d11eda in 32-bit code (0x0040d772).
Register dump:
 CS:0023 SS:002b DS:002b ES:002b FS:0063 GS:006b
 EIP:0040d772 ESP:0033fd90 EBP:0033fe7c EFLAGS:00010212(   - 00      - RIA1)
 EAX:00400000 EBX:7b8b5818 ECX:0033fd94 EDX:00000067
 ESI:00113bd1 EDI:00419fe0
Stack dump:
0x0033fd90:  00410db5 00000000 00400000 00000067
0x0033fda0:  00419fe0 00113bd1 7b8b5818 005705a8
0x0033fdb0:  7b867a11 0033fdd4 7bc33a4f 0010f250
0x0033fdc0:  7bc446b6 7bc44afb 00000018 00000065
0x0033fdd0:  00000000 00400000 00000067 00570054
0x0033fde0:  00000001 00000094 00000005 00000001
=>0 0x0040d772 in space (+0xd772) (0x0033fe7c)
  1 0x0041a132 in space (+0x1a132) (0x0033ff08)
  2 0x7b878b08 in kernel32 (+0x58b08) (0x0033ffe8)
0x0040d772: fmull 0xd5911eda(%eax)
Module Address Debug info Name (52 modules)
PE  400000-  459000 Export          space
PE 10000000-1000c000 Deferred        drvmgt
ELF 7b800000-7b93d000 Export          kernel32<elf>
  \-PE 7b820000-7b93d000 \               kernel32
ELF 7bc00000-7bcaf000 Deferred        ntdll<elf>
  \-PE 7bc10000-7bcaf000 \               ntdll
ELF 7bf00000-7bf03000 Deferred        <wine-loader>
ELF 7e6ba000-7e720000 Deferred        rpcrt4<elf>
  \-PE 7e6d0000-7e720000 \               rpcrt4
ELF 7e733000-7e739000 Deferred
ELF 7e739000-7e745000 Deferred
ELF 7e745000-7e749000 Deferred
ELF 7e749000-7e754000 Deferred
ELF 7e754000-7e75e000 Deferred
ELF 7e75e000-7e764000 Deferred
ELF 7e764000-7e768000 Deferred
ELF 7e768000-7e789000 Deferred        imm32<elf>
  \-PE 7e770000-7e789000 \               imm32
ELF 7e789000-7e78d000 Deferred
ELF 7e78d000-7e7b2000 Deferred
ELF 7e7b2000-7e7b8000 Deferred
ELF 7e7b8000-7e8f0000 Deferred
ELF 7e8f0000-7e902000 Deferred
ELF 7e902000-7e91b000 Deferred
ELF 7e91b000-7e923000 Deferred
ELF 7e943000-7e9dc000 Deferred        winex11<elf>
  \-PE 7e950000-7e9dc000 \               winex11
ELF 7ea2c000-7ea54000 Deferred
ELF 7ea54000-7ea8f000 Deferred
ELF 7ea8f000-7eab9000 Deferred
ELF 7eab9000-7eacd000 Deferred
ELF 7eacd000-7eb6e000 Deferred
ELF 7eb8e000-7eba2000 Deferred        lz32<elf>
  \-PE 7eb90000-7eba2000 \               lz32
ELF 7eba2000-7ebf6000 Deferred        advapi32<elf>
  \-PE 7ebb0000-7ebf6000 \               advapi32
ELF 7ebf6000-7ec95000 Deferred        gdi32<elf>
  \-PE 7ec10000-7ec95000 \               gdi32
ELF 7ec95000-7ede2000 Deferred        user32<elf>
  \-PE 7ecb0000-7ede2000 \               user32
ELF 7ede2000-7edef000 Deferred
ELF 7edef000-7edfb000 Deferred
ELF 7edfb000-7ee14000 Deferred
ELF 7ef9d000-7efe0000 Deferred
ELF 7efe7000-7f000000 Deferred        version<elf>
  \-PE 7eff0000-7f000000 \               version
ELF f73b8000-f73bd000 Deferred
ELF f73bd000-f756d000 Deferred
ELF f756d000-f7588000 Deferred
ELF f75a0000-f75a9000 Deferred
ELF f75a9000-f76e4000 Deferred
ELF f76e6000-f7707000 Deferred
process  tid      prio (all id:s are in hex)
0000001d   15
00000009    0
0000002f    0
0000002e    0
00000016    0
00000015    0
00000014    0
00000010    0
0000000f    0
00000017    0
00000013    0
00000012    0
0000001b    0
00000028 (D) C:\Program Files\NovaLogic\Tachyon\space.exe
00000029    0 <==
00000030    0
0000002d    0
0000002c    0
=>0 0x0040d772 in space (+0xd772) (0x0033fe7c)
  1 0x0041a132 in space (+0x1a132) (0x0033ff08)
  2 0x7b878b08 in kernel32 (+0x58b08) (0x0033ffe8)

I'm running Debian Jessie/Sid. I've tried Tachyon with several recent versions of WINE as well as WINE 1.1.14 as reported working on WineHQ.

I can't decypher anything that's breaking it in the debug output. I have Dx9 and nGLIDE installed in the same virtual drive but the errors were identical before I installed them.
booman Tuesday 21 January 2014 at 20:36

Interesting, I get this kind of error with Steam and the Steam Overlay breaking my games.
I recommend trying newer versions of Wine like stable 1.6.2 or even some of the newer ones...
Also, can you run any other games in Linux?

† Booman †
Mint 20.2 64-bit | Nvidia 470 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained