The forum

How do I Completely Disable POL_System_CheckFS?

Author Replies
svalbard Monday 15 September 2014 at 18:46
svalbardAnonymous

Hi,

I have POL 4.2.5 installed on Ubuntu 14.04 running on a Chromebook via Crouton. Microsoft Office 2010 was installed via POL and everything works perfectly. The Office files are installed in POL and the wineprefix folder is symlinked to an ext4 formatted external SD card mounted to a folder in /mnt/ via a startup script that gives full read and write permission to the drive. Everything works perfectly except for one minor annoyance that has been popping up since before I even installed Office. Every time I start PlayOnLinux, the "Your filesystem might prevent PlayOnLinux from running correctly. Please open PlayOnLinux in a terminal to get more details." screen pops up and I have to hit okay. Opening it in terminal, I get:

(trusty)andrew@localhost:~$ playonlinux
Looking for python... 2.7.6 - selected
[main] Message: PlayOnLinux (4.2.5) is starting
[clean_tmp] Message: Cleaning temp directory
[Check_OpenGL] Message: 32bits direct rendering is enabled
[Check_OpenGL] Message: 64bits direct rendering is enabled
[POL_System_CheckFS] Message: Checking filesystem for /home/andrew/.PlayOnLinux/
[FS_Check] Warning: The following file is located on a noexec mounted filesystem.
It might prevent wine from working

/home/andrew/.PlayOnLinux/
[main] Message: Filesystem is compatible

I tried the recommendation petch gave to someone with a similar issue, typing in POL_Config_Write NO_FSCHECK TRUE but the window continues to pop up. All I would like to do is completely disable the filesystem check at PlayOnLinux startup as I know the current setup works perfectly, making it to where I don't have to click OK every time I want to open a document in Office. It's a small but nice quality of life change.

Thank you so much for your help and for making this awesome program! It's made my life so much easier already.

Ronin DUSETTE Monday 15 September 2014 at 18:56
Ronin DUSETTE
Admin

Well, that error pops up for a reason; there is a good chance it will have problems. I am not sure how to disable it, but I am sure it is warning for a reason. I am sure one of the dev's could give a more technical explanation of the error and how to possibly disable it. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
petch Monday 15 September 2014 at 23:18
petch
Developer

I tried the recommendation petch gave to someone with a similar issue, typing in POL_Config_Write NO_FSCHECK TRUE but the window continues to pop up.

 

Typing it in where? Because it should still work.

 

Quentin PÂRIS Tuesday 16 September 2014 at 0:36
Quentin PÂRIS
Admin

I tried the recommendation petch gave to someone with a similar issue, typing in POL_Config_Write NO_FSCHECK TRUE but the window continues to pop up.

Typing it in where? Because it should still work.

svalbard Tuesday 16 September 2014 at 2:11
svalbardAnonymous

@petch: In the POL Console.

@Quentin: I believe you're correct. The reason I'm confused is because my SD Card has exec permissions in actual use, it just appears POL isn't recognizing it at launch (SD is sdb1):

(trusty)andrew@localhost:~$ mount | grep sda1
/dev/sda1 on / type ext4 (rw,relatime,commit=600,data=ordered)
(trusty)andrew@localhost:~$ mount | grep sdb1
/dev/sdb1 on /mnt/external type ext4 (rw,relatime,data=ordered)

Just for clarification, the .PlayOnLinux folder is located on sda1 and so are all of the other contents, except for the wineprefix folder (where Office is installed), which is a symlink to a folder on sdb1 as sda1 has limited storage.

Checking Office's logs, everything has been working perfectly and there have been no errors (in the logs, never noticed any during normal use outside of what was logged) after I ran sudo apt-get install libp11-kit-gnome-keyring:i386, something I didn't have it installed by default.

This is a fairly jury-rigged linux installation as is, being that it's through Crouton on a Chromebook. I'm just trying to disable the message to get rid of the minor annoyance of having to press OK every time I open a document. I was just seeing if there was an easy way to do it. If it's not possible, it's nothing to stress out about. It's been amazing to only carry around this little inexpensive laptop and still be able to do everything I normally do (Skype, even WoW on occasion) as I travel and work on my thesis.

So, I'm not sure where to go from here but thanks for your responses!