The forum

MetaTrader 5 & 64-bit

Author Replies
stephen Wednesday 22 April 2015 at 20:49
stephenAnonymous

Hello I am a mac user and for some time I have been waiting for an update that allows instalation and use of 64 bit drives.

I need this because I use MetaTrader 5 and now with recent updates a lot of the features that were previously available on 32 bit are no longer present because the developers of MetaTrader now expect most/ all their users to be on 64 bit. My mac is already configured as a 64 bit so it is frustrating to not be able to use 64 bit drives on PlayOnMac?

Can you guys help.

petch Wednesday 22 April 2015 at 21:01
petch
Developer

From what I understand, the OS X ABI is incompatible with a 64bit version of Wine.

PS. On the other hand, the 1.7.36 changelog mentions something about 64bit on OS X; So I don't know...

PPS Came cross this thread in wine-dev mailing list

Edited by petch

cashflowjaque Thursday 31 October 2019 at 18:27
cashflowjaqueAnonymous

hey guys, i have the same issue now in 2019, couldnt find any help online. I downloaded POM and the wine 4.11 version. But MT5 is still not working. 

I get this error:

translatet from german into english: 

 

Error in POL_Wine

The start of 64-bit-Process mt5setup (1).exe in 32-bit virtual drive is not supportet.

 

 

 

(germanoriginal:

Error in POL_Wine

Das Starten des 64-bit-Prozesses mt5setup (1).exe in 32-bit virtuellen Laufwerken wird nicht unterstützt.)

 

 

Support and help is highly apreciatet

 

Thanks in advance

 

Jaque

Dadu042 Thursday 31 October 2019 at 20:41
Dadu042
Moderator

It seems to me (according the message) that the app has switched from 32bits (x86) to 64bits (amd64) but the script is set for 32bits.
What is your OS and its version ? (and also: 32bits or 64bits ?).

Edited by Dadu042

andersonammelo Wednesday 20 November 2019 at 15:45
andersonammeloAnonymous

I’m having the same problem. I’d really appreciate any help of someone who could understand what is happening. Here is a description of what I’m doing:

I use the MAC OS High Sierra

Processor (Core i5), which I believe is a 64-bit processor

I have successfully installed the Play On Mac, and also separately installed the latest version of XQuartz (before doing this, the Play On Mac did not run on my MAC).

Then I select: Install a program >> install a non-listed program >> Manual installation

Two options:

1. Install a program in a new virtual drive

2. Edit or update an existing application (I select this option)

>>Show virtual drives (I select the drive I’ve created, and I don’t know how I did that, just remember the software asked me to give a name to a new driver)

>>What would you like to do before installation?

3 options:

1. use another version of wine (2 options)

  • System
  • The version of wine I have configured. I configured the one is the most recent in the list of Play on mac (4.19 staging).

2. configure wine (If I select configure wine, a window pops up, where I can select the many windows version up to windows 10. I select windows 7, and 10. Both doesn’t work)

3. install some libraries (I don’t select this option)

>> Select the version of installation

I have tried with both versions, none has worked and the same error will occur.

32 bits windows installation

64 bits windows installation

>> Please select the install file to run (I select the “mt5setup.exe”)

And voilà:

Error in POL_Wine

Starting 64-bit process /Users/andersonmelo/Downloads/mt5setup.exe is not supported in 32-bit virtual drives

It doesn’t matter the combination of options I use, the same error will come up at the end.

I have a feeling that some way the virtual drive I created is incompatible with 64-bit version of the software I’m trying to run.

Any help?

 

Thank you!