The forum

Age of Empires II : The Conquerors

the famous expansion

Author Replies
Ghostofkendo Monday 19 May 2008 at 22:32


Here is the script I made for the expansion of AoE II, The Conquerors:
if [ "$PLAYONLINUX" = "" ]
exit 0
source "$PLAYONLINUX/lib/sources"


#Game and script presentation
presentation "Age of Empires II : The Conquerors" "Microsoft" "" "Ghostofkendo" "AOE2" 1 5

#Language variables for the script's translation
if [ "$POL_LANG" == "fr_FR.UTF-8" ]; then
LNG_WAIT_END="Cliquez sur "Suivant" UNIQUEMENT lorsque l'installation est finie"
LNG_DL="Des dlls vont être téléchargées puis installées pour
faire fonctionner le multijoueur"
LNG_WAIT_END="Click on "Next" ONLY when the installation is finished"
LNG_DL="Some dlls will be downloaded then installed in order to
get the multiplayer working"

#Check if Age of Empires II : The Age of Kings is installed
verifier_installation_e "AOE2"

#Ask for the path to the game's CD-Rom and check the installer's presence
Ask_For_cdrom 2 5
Check_cdrom "aocsetup.exe"

#Display a message to warn the user that the game won't run without a NoCD patch but using it is illigal. So we don't provide it and we aren't reponsible of what the user choose to do.

#Game's prefix selection
cd $REPERTOIRE/wineprefix/AOE2
select_prefix "$(pwd)"

#Set Wine with Windows 2000 parameters. Mandatory to run the game.
Set_OS "win2k"

#Game's installation
wine $CDROM/aocsetup.exe
message "$LNG_WAIT_END" "" 3 5

#Cleaning PlayOnLinux's temporary folder if needed
if [ -d "$REPERTOIRE/tmp/AOE2TheConquerors/" ]; then
rm $REPERTOIRE/tmp/AOE2TheConquerors/ -R

#Creating a temporary folder for the remaining part of the installation
mkdir $REPERTOIRE/tmp/AOE2TheConquerors

#Download dlls, then move them and override them to get multiplayer working
cd $REPERTOIRE/tmp/AOE2TheConquerors/
download "$LNG_DL" "" "" 4 5 1
tar -xjvf dplaydlls-win98se.tar.bz2
mv *.dll $REPERTOIRE/wineprefix/AOE2/drive_c/windows/system32/
echo "[HKEY_CURRENT_USER\\Software\\Wine\\DllOverrides]" > $REPERTOIRE/tmp/AOE2TheConquerors/dll.reg
echo "\"dplayx\"=\"native,builtin\"" >> $REPERTOIRE/tmp/AOE2TheConquerors/dll.reg
echo "\"dpnet\"=\"native,builtin\"" >> $REPERTOIRE/tmp/AOE2TheConquerors/dll.reg
echo "\"dpnhpast\"=\"native,builtin\"" >> $REPERTOIRE/tmp/AOE2TheConquerors/dll.reg
echo "\"dpwsockx\"=\"native,builtin\"" >> $REPERTOIRE/tmp/AOE2TheConquerors/dll.reg
regedit $REPERTOIRE/tmp/AOE2TheConquerors/dll.reg

#Simulate the Windows' reboot
simulate_reboot 5 5

#Create a launcher for the game if the user agree
creer_lanceur "AOE2" "Program Files/Microsoft Games/Age of Empires II/age2_x1/" "age2_x1.exe" "Age of Empires II The Conquerors.ico" "Age of Empires II : The Conquerors"

#Cleanning PlayOnLinux's temporary folder
rm $REPERTOIRE/tmp/AOE2TheConquerors/ -R


The icon for the launcher is available HERE (16x16 seize)

Beware, the game don't run without a NoCD patch.

I tried it with Wine 0.9.61 under openSUSE. It runs well except that the texts in the main menu are black instead of white (so they are hardly readable) and the game lags a little bit (but it remains very playable).

Please test it and report here your experience.

shuryanc Friday 12 September 2008 at 11:27

can you play multiplayer?
lucho115 Tuesday 1 September 2009 at 19:19

iam traing to install it and it say "error: no cdrom found" , why? iam using a folder not a real cd, but when tried wit the real cd its say the same error.
NSLW Wednesday 2 September 2009 at 17:47

You've got wrong version of AOE II, it may be that it's illegal.