The forum

How to use "Try this update"

Author Replies
Damian21 Tuesday 13 February 2018 at 6:52

Hello people, I'm new on linux trying to install League of Legends. The official script doesnt seem to work so someone commented a new one. At his comment there is a button named "Try this update" but when i click it firefox opens a new tab "playonlinux://" and nothing happens. Can anyone guide me through it please? This is the link of the topic for league of legends

Tutul Tuesday 13 February 2018 at 17:14

On some system POL failed to be registred as a service that can open playonlinux protocol. Since I change my OS, I got the same problem, I read docs, find the fix and post it here ;)


Gentils modérateur dans mes bon jours - Attention, à tenir hors de portée des enfants. En cas de contact, veuillez immédiatement rincer à l'eau clair. Peut provoquer des sueurs froide !
Damian21 Wednesday 14 February 2018 at 19:12

I found a way around it. I copied the new code (without the numbers) to a text editor and run a new script (Tools - Run a local script).

Noserenity Saturday 16 June 2018 at 1:36

I just wanted to bump this and say thanks to Damian21. That worked for me!

eddi71 Wednesday 29 August 2018 at 14:46

Super, the script option was the only option that worked for a patch with regard to Microsoft Office 2010 of July 2018. Installing this new script straight from Firefox did not work, even after adding a playonlinux-url_handler program via about:config in Firefox.

Two obervations for less-than-power-users:

1) The script, once copied to the text editor, needs to be saved as a TXT file. Remember the location of the file and choose it in the appropriate window.

2) Under Kubuntu 18.04.1, I got to the next stage (after selecting the TXT file with the script that I had saved), where the window asked me to check the script. This windows was blank. I thought something had gone wrong and restarted this process repeatedly. But the script had acutally been loaded each time (check in /usr/share/playonlinux/temp). Simply click on "continue", and the installation process for the actual application will launch. Whether or not the script was correct should be clear from success/failure of that installation.


kreyren Saturday 20 April 2019 at 8:15

> I found a way around it. I copied the new code (without the numbers) to a text editor and run a new script (Tools - Run a local script).


donjoe Sunday 1 March 2020 at 0:59

I just came across this problem myself, and it seems support might be missing in the POL application itself, because neither the playonlinux nor the playonlinux-pkg executables have any help text about any option to open any special URLs. So even if I follow one of the various guides about how to manually add a custom URI handler to *buntu (e.g., I still won't have any working command to add as the Exec parameter for the new .desktop file.

So I guess that copy-paste workaround is the only way to do it for now.

AMD FX-8320 8-core @3.5 GHz / 8 GiB DDR3 @1600 MHz / NVidia GT440, 1 GiB DDR3 / Xubuntu 14.04 x64