The forum

Kindle for PC

Author Replies
nPrime Wednesday 17 July 2019 at 15:10

The automatic installer for Play On Linux no longer works if you choose to download the install files automatically (probably because it downloads a higher version than works with the Play On Linux script), so here's what I've found with manual installs ("Install a non-listed program").


I'm running openSUSE Tumbleweed and used 32-bit WINE version 4.12.1 with no other configuration changes (besides mono when the virtual drive was created).


I downloaded installers from FileHippo:


The highest Kindle version you can install in which you can log into your Amazon account is 1.17.1. Running installers higher than 1.17.1 will fail before reaching this point.

You can install up to version 1.21 if you first install version 1.17.1, log into your Amazon account, then:


  • "Install a program" after starting Play On Linux
  • Install a non-listed program
  • Edit or update an existing application
  • Select the previous 1.17.1 install, select the executable for the higher version installer, and proceed with the installation.


While you CAN install up to version 1.21 using this method, one reason you might not want to is the program's startup time. With version 1.17.1, it usually takes 5 to 6s for the program to start while it takes about 13s for higher versions to start on my machine. Something to consider if you don't need the features from higher versions (I don't know the added features between 1.17.1 and 1.21 though).


If you want to test it, you can backup the folder for the virtual drive (from /home/username/.PlayOnLinux/wineprefix/) before upgrading, install the upgrade, see if you like it, and if you don't, delete the folder and copy the folder you backed up back into the wineprefix folder to quickly get back to 1.17.1.

Edited by nPrime

Dadu042 Wednesday 17 July 2019 at 18:02

Thank you for your detailed report and tricks.
For your information I upgraded the script (v1.11 -> 1.17). Please test and report if work or not (I've only opened a .PDF with).

Edited by Dadu042

nPrime Wednesday 17 July 2019 at 19:16

Glad to help!

I tried installing from the script but the install didn't proceed past the screen in which you view the code, check the box saying "I Agree" and click Next.


I haven't run a PlayOnLinux script before, though, so I might not be doing it correctly.


This is the process I used. Could you let me know if I need to do anything different?

  • Copied the text of the script and saved it in a text file named "" in my Documents directory (If I click the "Try this update" button on your post, I get the error "The address wasn’t understood" in Firefox)
  • On the main PlayOnLinux screen, go to Tools > Run a local script > Next > Browse to the saved script > Next > Next (warning screen) > Check box "I Agree" on the source code screen > Next.

The window then closes and nothing more happens.

Same thing happens if I use the source code from Fekir's post above yours.


Same thing if I "chmod +x" before doing the above process. Not sure if I should try to run it outside of PlayOnLinux or if it needs to be run through the PlayOnLinux UI.


Tried again, this time through the normal installer (Install a program > Accessories > Amazon Kindle > Download install file) in case you pushed the changes there. With this, the installer hangs at "Please wait while the virtual drive is being created..."


The issue could be trying to get the installer from:

When I visit the page on Firefox, I get to a page that says:


This snapshot cannot be displayed due to an internal error.


  • Tested it again when was working properly - same result.
  • Tried it again, this time choosing to use a local installer rather than download -  same result, so the issue is before the download.
  • Rebooted, tried again - same result.
  • Removed and reinstalled WINE 2.22, tried again - same result.
  • Tried installing a different program (Notepad++) - install was successful. So it doesn't appear to be an issue with my machine.
  • I notice the install is hanging at the point where it usually prompts you to install mono, so maybe that's related to the problem.

Edited by nPrime

sentinal Saturday 14 December 2019 at 20:39

I have the same problem.....

Dadu042 Sunday 15 December 2019 at 10:28

nPrime: my script had a little bug, fixed on 23 July 2019  by Gurran.  Pol script files are text files renamed to ".pol".

Sentinal : more details please.

This site allows content generated by members, and we promptly remove any content that infringes copyright according to our Terms of Service. To report copyright infringement, please send a notice to