The forum client

Author Replies
nPrime Wednesday 17 July 2019 at 16:32
nPrimeAnonymous is a Dropbox alternative that uses end-to-end encryption (so employees at Sync are not able to see your data, as it is encrypted before leaving your device).



  • Client is closed-source
  • Based in a 5 Eyes country (Canada)



  • Canada does not have laws that allow them to legally demand data from service providers and prevent them from talking about it with a gag order (what makes US-based services more risky to use). If you assume your data really is being end-to-end encrypted (can't verify, though, since the client is closed source), Sync would only have access to unencrypted metadata, so would be limited in what they could share.
  • 5 GB available for free


Limitations and workarounds:

  • I can either left or right-click the notification-area icon to bring up the menu. If I right-click, I'm not able to close the menu until I select something from it. If I left-click the icon to bring up  the menu, I can dismiss it by clicking elsewhere, so you can avoid the annoyance by only left-clicking the icon.
  • The option to "Run when the computer is started" doesn't work (need to manually start it each time or use some other means to run the program after booting Linux).
  • You can't create links to files (to share files with others) from the desktop - you need to do this through the web-portal.
  • I get an error if I go to Preferences > Account tab. This tab has options to change the password, export a list of files, and uninstall. Export works but I haven't tested changing my password or uninstalling (which shouldn't be an issue as you can change your password on the website).
  • The font size on the menu is small. You can enlarge it by clicking Configure > Select the virtual drive for Sync > Wine tab > Configure Wine > Desktop Integration > Menu Text > change the font size.
  • Double-clicking the sync icon will bring up the sync folder but in an interface with limited functionality (can't Create Link) and poor usability (small font size, dated looking UI). Probably better to create a shortcut to this folder with your distro's normal file explorer.


Running openSUSE Tumbleweed

Use 32-bit WINE version 4.4


I tried with WINE version 4.12.1 and it installed successfully but when I quit the program, it crashed when I tried to restart it afterwards. A workaround was to simulate a Windows reboot in WINE and then start the program again. Version 4.4 doesn't have that issue. I didn't test any versions other than 4.4 and 4.12.1 (I picked 4.12.1 because it's the latest at the time of this writing and 4.4 because someone on WineHQ mentioned using 4.4 successfully).


Comments on install:

  • You can have 2 factor authentication enabled with your sync account and install it successfully.
  • If you want to point it to an existing Sync folder (perhaps from a Windows install), select the parent of the sync folder. So if you have an existing folder at "C:/Sync" use "C:" as the path in the installer.
  • Authorizing the install can be tricky and unclear. More on this below.


The first time you run it, it will index existing content and then tell you (on the menu if you click the icon) that you need to authorize the device. There will probably be an option on the menu to go to the website to do this. Select the option and it will take you to the web portal to log in.

  • After you log in, it will take you to a screen with a pop-up that ends with an "authorize" button.
  • If you click that button, the popup will vanish and you will see a list of devices. Among that list will be the device you're using, but it will have a green "authorize" button near the end of it. You don't need to click this button - you've already authorized it from the pop-up but the page underneath the pop-up was generated before you authorized it, so is showing outdated info. Refresh the page and you should see the option to authorize it vanish.
  • After I authorized it on the website, my client's menu still said it was unauthorized. I quit and restarted the client a few times before the "unauthorized" message vanished and it started syncing.

If you install the Sync client more than once (testing different WINE versions) and log in on the installer, it will create an authorization entry each time on the website (that you won't see unless you log in and go to the page - click your account name at the upper right > Settings > Devices tab), each with a green authorize button.


Each of those entries is linked with the install that generated it, so if you click "authorize" for one from a previous (now deleted) install, it won't authorize your current install - you need to click authorize on the proper line (or the authorize button from the pop-up). This is probably the last "Desktop" entry on the list (unclear since it only shows the date added and not the time).


You could authorize all entries and this would work, if you don't mind having a bunch of "dud" entries on your list. If you accidentally delete the authorization for your current install, your sync will go offline, as it is no longer authorized. To fix this, you need to scroll down to the bottom of the list, click "Show Deleted" and restore the entry. This can be tricky if you've deleted multiple entries which have the same name (I'd guess it to be the lowest deleted entry on the list, assuming it is listed in chronological order). I haven't found a way to get the sync client to generate a new authorization request.

Edited by nPrime

This site allows content generated by members, and we promptly remove any content that infringes copyright according to our Terms of Service. To report copyright infringement, please send a notice to