The forum

Megaman Maker runs using configure: Miscellaneous: Run a .exe

Doesn't run using the usual way of starting exe.

Author Replies
islanddon Thursday 9 January 2020 at 21:20
islanddon

Hi, everyone!

I've been trying to get the latest Megaman Maker to run using Wine and realized that after installed Play On Mac to run SMBX, the Finder was now suggesting I open megamaker.exe with PlayOnMac.

I've been running PlayOnMac by executing ./playonmac --verbose from inside /Applications/PlayOnMac.app/Contents/MacOS.

I'm trying to remember exactly what I did, but I think I was prompted to set up a manual installation, which I did. At some point, it said it was analyzing the application. I also remember that I was prompted with an "Open File"-type dialog box, so I selected Megamaker.exe. The terminal then showed something about connecting the debugger and everything seemed to stop working.

Eventaully, I went to the main PlayOnMac window and selected Configure, picked Megamaker, opened the task manager, and killed the process for Megamaker.exe, which seemed to be running. Every time I try to start the game though the PlayOnMac UI, I get that same dialog box. If I pick megamaker.exe The console also shows this:

Start debug server
Creating Debugger server port:6502
[DbgServer]6502
Total memory used = 7877988(0x00783564) bytes
...Waiting for debugger to connect...

The EXE never actually shows me a UI doing this, though a process starts (checking via the Task Manager) and an icon shows up in my dock.

If I go to Configure: Miscellaneous: Run a .exe in this virtual drive and pick MegaMaker.exe (through the Mac UI), everything works great, including none of the graphics issues I had been getting running straight wine through the terminal.

(I still get that Index out of bounds exception every time, but that seems to be a known issue running Megamaker in wine with no ill effects.)

Thoughts? Thanks! Apologies in advance if this is the wrong place to post this.

Edited by islanddon

Dadu042 Thursday 9 January 2020 at 22:03
Dadu042
Moderator

First thing to know: http://wiki.playonlinux.com/index.php/Manual_Installations

I'll try to write a script for this game.

islanddon Friday 10 January 2020 at 1:48
islanddon

Good to know. Thanks for the quick reply!

Dadu042 Friday 10 January 2020 at 13:12
Dadu042
Moderator

Great platform game, script made.

islanddon Monday 13 January 2020 at 4:01
islanddon

Hey, Dadu. Thanks for getting a script made. Unfortunately, it doesn't work for me. When I try to run the script after launching PlayOnMac through the console I get the following. Thoughts?

This is the output from the second attempt at running this. The first attempt failed, but I didn't have the console open, so I don't have that output. Thanks!

My-Computer:~ MyUser$ /Applications/PlayOnMac.app/Contents/MacOS/playonmac
2020-01-12 21:56:42.109 defaults[2451:75246]
The domain/default pair of (com.apple.dock, loc) does not exist
/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.60.1/Common/ChunkCompression.cpp:49: Error: unsupported compressor 8
/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.60.1/Libraries/CompressData/CompressData.c:353: Error: Unknown compression scheme encountered for file '/System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/Exceptions.plist'
/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.60.1/Common/ChunkCompression.cpp:49: Error: unsupported compressor 8
/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.60.1/Libraries/CompressData/CompressData.c:353: Error: Unknown compression scheme encountered for file '/System/Library/CoreServices/CoreTypes.bundle/Contents/Library/AppExceptions.bundle/Exceptions.plist'
[main] Message: PlayOnMac (4.3.4) is starting
[clean_tmp] Message: Cleaning temp directory
[install_plugins] Message: Checking plugin: ScreenCap...
[update_check] Message: List is up to date
[POL_GPG_auth_script] Message: Checking signature of /Users/MyUser/Library/PlayOnMac//install
[POL_GPG_install_key] Message: Importing PlayOnMac public key
[POL_Bash] Message: POL GPG : Good signature -
[POL_SetupWindow_Init] Message: Creating new window for pid 2868
[POL_Wine_SelectPrefix] Message: Selecting prefix: mega_man_maker
[POL_System_SetArch] Message: POL_ARCH set to amd64
[POL_System_SetArch] Message: POL_ARCH set to amd64
[POL_Wine_PrefixCreate] Message: Setting POL_WINEVERSION to 3.0.3
[POL_Wine_PrefixCreate] Message: Creating prefix (3.0.3)...
[POL_Wine_PrefixCreate] Message: Prefix already exists
[POL_SetupWindow_menu] Message: menu answer: Erase (virtual drive content will be lost)
[POL_Wine_PrefixCreate] Message: Erase Prefix
[POL_Wine_PrefixCreate] Message: Using wine 3.0.3
[POL_Wine_InstallVersion] Message: Installing wine version path: 3.0.3, amd64
[POL_Config_PrefixWrite] Message: Prefix config write: ARCH amd64
[POL_Config_PrefixWrite] Message: Prefix config write: VERSION 3.0.3
[POL_Wine] Message: Running wine-3.0.3 --version (Working directory : /Users/MyUser/Library/PlayOnMac/shortcuts)
[POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonmac.com/fr/page-26-Winemenubuilder.html
[POL_Wine] Message: Wine return: 0
cat: /Users/MyUser/Library/PlayOnMac//tmp/glxinfo: No such file or directory
cat: /Users/MyUser/Library/PlayOnMac//tmp/glxinfo: No such file or directory
0012:err:ole:marshal_object couldn't get IPSFactory buffer for interface {00000131-0000-0000-c000-000000000046}
0012:err:ole:marshal_object couldn't get IPSFactory buffer for interface {6d5140c1-7436-11ce-8034-00aa006009fa}
0012:err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hres=0x80004002
0012:err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, 80004002
0012:err:ole:get_local_server_stream Failed: 80004002
0014:err:ole:marshal_object couldn't get IPSFactory buffer for interface {00000131-0000-0000-c000-000000000046}
0014:err:ole:marshal_object couldn't get IPSFactory buffer for interface {6d5140c1-7436-11ce-8034-00aa006009fa}
0014:err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hres=0x80004002
0014:err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, 80004002
0014:err:ole:get_local_server_stream Failed: 80004002
0017:fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
0017:err:mscoree:LoadLibraryShim error reading registry key for installroot
0017:err:mscoree:LoadLibraryShim error reading registry key for installroot
0017:err:mscoree:LoadLibraryShim error reading registry key for installroot
0017:err:mscoree:LoadLibraryShim error reading registry key for installroot
0017:fixme:msi:internal_ui_handler internal UI not implemented for message 0x0b000000 (UI level = 1)
0017:fixme:msi:internal_ui_handler internal UI not implemented for message 0x0b000000 (UI level = 1)
001b:fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
001b:fixme:msi:internal_ui_handler internal UI not implemented for message 0x0b000000 (UI level = 1)
001b:fixme:msi:internal_ui_handler internal UI not implemented for message 0x0b000000 (UI level = 1)
0010:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
0010:fixme:dwmapi:DwmIsCompositionEnabled 0x6dbd1518
001d:fixme:iphlpapi:NotifyIpInterfaceChange (family 0, callback 0x69ebd3de, context 0x8d6700, init_notify 0, handle 0x11cfa40): stub
0010:fixme:winsock:set_dont_fragment IP_DONTFRAGMENT for IPv4 not supported in this platform
0010:err:module:load_builtin_dll failed to load .so lib for builtin L"winegstreamer.dll": dlopen(/Users/MyUser/Library/PlayOnMac/wine/darwin-amd64/3.0.3/lib64/wine/winegstreamer.dll.so, 258): Library not loaded: /opt/local/lib/libgobject-2.0.0.dylib
  Referenced from: /Users/MyUser/Library/PlayOnMac/wine/darwin-amd64/3.0.3/lib64/wine/winegstre
dbus[3388]: Dynamic session lookup supported but failed: launchd did not provide a socket path, verify that org.freedesktop.dbus-session.plist is loaded!

Edited by islanddon

Dadu042 Monday 13 January 2020 at 16:09
Dadu042
Moderator

It seems that the main issue is :

failed to load .so lib for builtin L"winegstreamer.dll"

Perhaps look at : http://wiki.playonlinux.com/index.php/Troubleshooting_Common_Problems#Missing_files

islanddon Sunday 17 May 2020 at 7:23
islanddon

Hello again. So I never got this working quite right on my Mac, but I'm now using a Mint 19.3 machine as a media computer and am giving this another whirl, this time using PlayOnLinux. Everything seems to be working! Thanks for your help!

Edited by islanddon