The forum

Star Trek Online crashes when trying to enter certain maps.

Author Replies
NoIdea Sunday 30 January 2022 at 7:24

I've got Star Trek Online running under standard Wine 5 set to Windows 10 mode. 


I'm running it on Zorin OS Lite 12 (a variant of Ubuntu Xenial - yes, I know it's an old one).  HP Pavilion 15-cw0995na laptop, Ryzen 5 processor, Radeon Vega 8 graphics, 8 GB RAM (spec here).


(I haven't actually managed to run it with the PlayOnLinux script - it puts up an error saying "Upgrade to a graphics card that supports DirectX 11.0".  I've also tried using PlayOnLinux to install it manually and run it under Wine 7, but when I do that it puts up an error saying "32-bit Windows no longer supported" - whether I selected 32-bit or 64-bit.)


But a strange bug happens.  Whenever I try to enter certain maps, the game goes through the "Loading X%" screen as normal, and then crashes back to the desktop - no error message, just disappears.  The same thing then happens if I try to log in on that character again, since the game seems to record them as being in the map I tried to enter and therefore it tries to load it.  The only way I've been able to retrieve characters when this happens is to contact Star Trek Online's Technical Support and them move the character manually to a different map.


Maps with which the error has happened include Earth Spacedock, the Training Day map that new Starfleet characters start out on, a planet called something like Khufano that appears in one mission, and the Delta Quadrant command base.  These are all ground maps rather than space maps - I suspect it's just doing it with all ground maps.


Are other people having this problem?  If so, do you know a fix for it?

Edited by NoIdea

Dadu042 Wednesday 2 February 2022 at 13:44

Perhaps you may try instead with :

Edited by Dadu042

NoIdea Saturday 19 February 2022 at 7:28

Just tried that (sorry, didn't see your message before, as I thought the e-mail notifications on this forum worked and they don't). 

Unfortunately, that doesn't work - CrossOver tried to run it in Windows 7 mode, and Star Trek Online has recently dropped compatibility with Windows 7 and refuses to even try to run like that.  Presumably CrossOver's records for Star Trek Online are out of date.  It does say on the CodeWeavers page you linked to that that one was "Modified October 22, 2018".  And it seems from CrossOver's Help file that you can't alter the Windows version on a bottle after it's been created.

I could try a plain "bottle", but I'm not sure that that would make any difference.  And reinstalling Star Trek Online takes a long time with the speed of our Internet connection, so it would be a tall order to test it.

It turns out that reducing the graphics settings to minimum will make it work on ground maps for a while, but it'll crash unpredictably when the character moves into a particularly complicated map.  I don't know whether that narrows down what could be wrong with it at all.