The forum

Should this even work? Ideas on how to proceed?

Star Trek Online on Catalina MBP i9/5500M

Author Replies
RogerWilco Thursday 7 July 2022 at 1:55

Hello everyone,


I am not very experienced with PlayOnMac, but have dabbled with Wine in the past with various levels of success.

I am currently trying to get the game Star Trek Online to run on my Macbook Pro 2019 intel i9, Catalina, AMD Radeon Pro 5500M/4GB

I have started from

1) I could not get the default recipe to install the game. I downloaded the bash script and started editing.

1a) I had to edit the URL, replacing spaces with %20.

1b) I had to change the checksum, the one in the script seems out of date. (Cryptic updates their launcher frequently).


2) I then could get the game to install. No luck running it.

2a) It complained my OS was not supported. Changed the Wine OS from Windows 7 to Windows 10. That made it stop complaining.

2b) It complained my graphics card was "too old" and not supported. I guess it was trying to use the ancient OpenGL implementation in Catalina.

2c) Installing things that looked like DirectX10 or DirectX11 did nothing.


3) I guess I might need to try molten-vk instead of OpenGL, the game requires DX11.

3a) Installed molten-vk with homebrew.

3b) Changed the graphics setting from opengl to gdi.

3c) Installed DXVK 1_10, which seems the newest one? There are a lot of different ones, with inconsistent numbering??? This very confusing.

3d) Now it no longer complains and actually tries to start, but crashes.


4) Looking up which version of Wine should actually support vulkan and my Radeon 5500M

4a) The current script for Star Trek Online sets Wine to 6.0.1, but it seems I need some version of Wine 7 at least for 5500M support.

4b) Tried with various versions of Wine 7, up to 7.11, made no noticeable difference.

4c) Also tried installing the x86on64 versions, but those don't show up as an option even after downloading them??? Again very confusing. I thought I might need these, they seem to follow Crossover numbering and that seems to support Catalina since version 20?


  • Any idea if with my system (MacOS Catalina, i9/16GB, AMD 5500M/4GB) I even have a system that could work?
  • Any clue on how I could proceed? I'm not seeing any errors that I give me a clue.
  • In some descriptions on the internet, I see next to "gdi" and "opengl" also a 'vulkan" option, but that is not there. Should it be?
  • Do I need a different Wine?
  • Is there a way to test if my molten-vk even works?

Thanks for any help.

Edited by RogerWilco

RogerWilco Thursday 7 July 2022 at 2:02

See also my comments in

This site allows content generated by members, and we promptly remove any content that infringes copyright according to our Terms of Service. To report copyright infringement, please send a notice to