The forum

World of Warcraft

Author Replies
Nozridim Friday 15 January 2010 at 4:37

Hello everyone that is reading :)

Well im new to this forum and aswell kinda new to Linux aswell

I have tested Linux for alittle wile now and then, but its kinda hard for me so fare but im giving it a try.


Im using the new Ubuntu desto u call it, I think 9.10 verson

And im tryinging to install World of Warcraft Wrath of The Lich King, but so fare not so good at all. I have follow'd what someone else told on an other topic of WoW on how to do this, but i cant fix the last part out on this CD, it seems to me that its Locked. I have managed to Install WoW Classic and WoW TBC with Wine. But i cant launch the game for Updates or anything.

The thing that happends if i try to launch it is that i get meny pritty colors and tings and the game wont launch at all, then i have to restart my computer again to fix the graphic's.

Is there anyone out there (On this forum) that might help me with my problem, if so then i will be most gratefull :)

Best Regards
Dr Phil Friday 15 January 2010 at 16:13
Dr Phil

The (by far) easiest way to install it on Linux is just to copy it from an already made installation. If you have any chance to do that, please do. I've no experience what-so-ever about installing WoW, neither on M$ Windoze or Linux, so I can't really help you here. Good luck anyway, I hope someone else might be able to help you.
Nozridim Friday 15 January 2010 at 22:55

Well that is what i have try'd aswell

I have WoW on my W7 Partition on the Hard drive, and i made it so far that i can "launch" the game.
But i have done alittle research ofcourse and made changes to the Config file for WoW, and added Open Gl mode for the graphic's. and fixed shadow rending and such. But! the prob is that when i launch the game i get all these pritty colors everywhere, some purple and som red and such :P

Beside i kinda cant install WOTLK on PoL either couse it aint there. Only WoW Classic and TBC is to be found. So im wondering if maybe it can be added? Or maybe i can do it my self, and if so how do i do that? Im a compleate retard at this, but i want to use Linux and not Windows!! :p

I hope there is someone that can help me with this :)

Nozridim Saturday 16 January 2010 at 8:41

It works!!!

Now everything is all good <3 and i made it, What i did was just some more research and i finelly made it :)

So what did i do? Well im dual booting on my system, I have Windows 7 and Ubuntu 10.4
What i did was that i launched WoW from my C drive on the Windows folder and it almost worked there, but anyways.

Then i did this command in a Terminal

sh winetricks vcrun2005sp1 vcrun2005

and then u just wait for the system to update, it come's some popups about licence thingys but just press "Yes"

After that i deleted my WTF Folder and launched the game again to make a new WTF folder. Then i added.
SET gxAPI "OpenGL"
Too the file in the WTF folder.

So this is how my file looks like now.

SET locale "enGB"
SET portal "eu"
SET realmList ""
SET patchlist ""
SET coresDetected "2"
SET hwDetect "0"
SET gxRefresh "60"
SET gxMultisampleQuality "0.000000"
SET gxFixLag "0"
SET videoOptionsVersion "2"
SET movie "0"
SET Gamma "1.000000"
SET showToolsUI "1"
SET Sound_OutputDriverName "System Default"
SET Sound_MusicVolume "0.40000000596046"
SET Sound_AmbienceVolume "0.60000002384186"
SET farclip "727"
SET specular "1"
SET groundEffectDensity "24"
SET projectedTextures "1"
SET gxVSync "0"
SET readTOS "1"
SET readEULA "1"
SET readTerminationWithoutNotice "1"
SET gxAPI "OpenGL"

Its nothing else i added then SET gxAPI "OpenGL" to the file.
I can also fix whatever i want now from Screen Reselution and Graphics, or most of it atleast. The good part is that i have like 120 FPS aswell(Something i dident have in W7)

My stats on my computer is abit old though it works.
I also read that ATI graphic's cards has some problems with this game, but just make sure that the Catalyst is fully updated, and maybe update your system fully aswell?

Just do this and everything might work for u aswell, but im going to do some more research and ill be here atleast one's aday :) so just add a reply if u run into a problem and i might help u :)

Anyways enough writing, i got some playing to do :D

Uber Best Regards
n.byron.griffin Thursday 10 November 2011 at 3:18

I'm having a problem with WoW not installing now. Using Wine 1.2, Ubuntu 11.10 and my system basics are:
Asus M4A87TD MB
AMD X2 255 dual core 3.1ghz
8MB Gskill DDR3 1333 PC3 ram
Asus ENGTX460 PCIe
I've downloaded the game client and begin the install. The launcher updates and then downloads 3-5 mb of data then gives me a general "You may have a problem with WINE" error and terminates. Any help you can provide would be greatly appreciated.
Caleb4 Thursday 2 February 2012 at 5:29

I did everything "Nozridim" said to do that worked for him, it seemed to install and work also for me, BUT, were the hell is the file??? i use linux mint, and i cant find the damn file to open it, any help? or terminal launches?
Caleb4 Thursday 2 February 2012 at 17:40

I have an old GeForce 6600GT (AMD), yea its the best amd u can get, it can run it fine (with my standards)....

how do i find the file?

there was also an error right before the INstallation page came up and installed perfectly, said something about being unable to find the file, which makes no sence to me and i dont think that matters or is an important error.

Please help
Caleb4 Thursday 9 February 2012 at 0:04

got it, nevermind, open it under "WineTricks" works beautifully. thank you much.
Deleted spam
chopdoc Friday 5 October 2012 at 9:47

I am new to linux but had good sucess doing this. I went to Play on Linux and installed the basic free world of warcraft from Blizzard. Then I copied my entire warcraft folder from my DOS partition and pasted it over the one I just installed in my home/mine/.playonlinux virtual drive. It worked flawlessly. I also play on a private server that uses Warcraft 2.1.4 version. I made a second directory in the virtual drive, pasted my stuff there and that also works with no problems.