The forum

PlayOnMac don't start

Author Replies
Kuufi Tuesday 8 November 2011 at 9:55
KuufiAnonymous

Well it says "PlayOnMac has encountered a fatal error, and will now terminate". Im using a proper MacOsX 10.7.2 on Macbook Pro 2010 Early model. Is there any fix for that?

I just downloaded PlayOnMac 4 1.0.13 (latest). After download, i dragged that to application folder. and started PlayOnMac.app. Then it goes for about 5-8 sec. And then I get this error.

Thanks :)
Quentin PÂRIS Tuesday 8 November 2011 at 18:39
Quentin PÂRIS
Admin

I need to know what is the error
Kuufi Tuesday 8 November 2011 at 19:32
KuufiAnonymous

I don't know if it helps, but i copied all the stuff from console


08.11.11 20:29.14,965 [0x0-0x2d62d6].org.playonmac.playonmac: 2011-11-08 20:29:14.940 defaults[41920:707]
08.11.11 20:29.14,965 [0x0-0x2d62d6].org.playonmac.playonmac: The domain/default pair of (/Users/kaupo/Library/Preferences/com.apple.dock.plist, loc) does not exist
08.11.11 20:29.15,000 kernel: CODE SIGNING: cs_invalid_page(0x1000): p=41981[playonmac.real] clearing CS_VALID
08.11.11 20:29.27,978 [0x0-0x2d62d6].org.playonmac.playonmac: [install_plugins] Message: Plugina kontroll: Wine Look...
08.11.11 20:29.30,121 [0x0-0x2d62d6].org.playonmac.playonmac: Traceback (most recent call last):
08.11.11 20:29.30,121 [0x0-0x2d62d6].org.playonmac.playonmac: File "/Applications/PlayOnMac.app/Contents/Resources/__boot__.py", line 137, in <module>
08.11.11 20:29.30,140 [0x0-0x2d62d6].org.playonmac.playonmac: _run('mainwindow.py')
08.11.11 20:29.30,140 [0x0-0x2d62d6].org.playonmac.playonmac: File "/Applications/PlayOnMac.app/Contents/Resources/__boot__.py", line 134, in _run
08.11.11 20:29.30,140 [0x0-0x2d62d6].org.playonmac.playonmac: execfile(path, globals(), globals())
08.11.11 20:29.30,140 [0x0-0x2d62d6].org.playonmac.playonmac: File "/Applications/PlayOnMac.app/Contents/Resources/playonlinux/python/mainwindow.py", line 657, in <module>
08.11.11 20:29.30,173 [0x0-0x2d62d6].org.playonmac.playonmac: app = PlayOnLinuxApp(redirect=False)
08.11.11 20:29.30,173 [0x0-0x2d62d6].org.playonmac.playonmac: File "/Applications/PlayOnMac.app/Contents/Resources/lib/python2.7/lib-dynload/wx/_core.py", line 8470, in __init__
08.11.11 20:29.30,363 [0x0-0x2d62d6].org.playonmac.playonmac: self._BootstrapApp()
08.11.11 20:29.30,363 [0x0-0x2d62d6].org.playonmac.playonmac: File "/Applications/PlayOnMac.app/Contents/Resources/lib/python2.7/lib-dynload/wx/_core.py", line 8035, in _BootstrapApp
08.11.11 20:29.30,379 [0x0-0x2d62d6].org.playonmac.playonmac: return _core_.PyApp__BootstrapApp(*args, **kwargs)
08.11.11 20:29.30,379 [0x0-0x2d62d6].org.playonmac.playonmac: File "/Applications/PlayOnMac.app/Contents/Resources/playonlinux/python/mainwindow.py", line 601, in OnInit
08.11.11 20:29.30,380 [0x0-0x2d62d6].org.playonmac.playonmac: self.frame = MainWindow(None, -1, os.environ["APPLICATION_TITLE"])
08.11.11 20:29.30,380 [0x0-0x2d62d6].org.playonmac.playonmac: File "/Applications/PlayOnMac.app/Contents/Resources/playonlinux/python/mainwindow.py", line 111, in __init__
08.11.11 20:29.30,380 [0x0-0x2d62d6].org.playonmac.playonmac: self.filemenu.Append(wx.ID_OPEN, _("Run"))
08.11.11 20:29.30,380 [0x0-0x2d62d6].org.playonmac.playonmac: File "/Applications/PlayOnMac.app/Contents/Resources/lib/python2.7/lib-dynload/wx/_core.py", line 11847, in Append
08.11.11 20:29.30,609 [0x0-0x2d62d6].org.playonmac.playonmac: return _core_.Menu_Append(*args, **kwargs)
08.11.11 20:29.30,609 [0x0-0x2d62d6].org.playonmac.playonmac: UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 1: ordinal not in range(128)
08.11.11 20:29.32,676 [0x0-0x2d62d6].org.playonmac.playonmac: [maj_check] Message: Web version : 1320766614
08.11.11 20:29.32,708 [0x0-0x2d62d6].org.playonmac.playonmac: [maj_check] Message: Current local version : 1320737041
08.11.11 20:29.32,713 [0x0-0x2d62d6].org.playonmac.playonmac: [maj_check] Message: Updating list
08.11.11 20:29.33,223 com.apple.launchd.peruser.501: (com.logmein.hamachimb[43792]) posix_spawn("/Applications/LogMeIn Hamachi/LogMeIn Hamachi Menubar.app/Contents/MacOS/LogMeIn Hamachi Menubar", ...): No such file or directory
08.11.11 20:29.33,224 com.apple.launchd.peruser.501: (com.logmein.hamachimb[43792]) Exited with code: 1
08.11.11 20:29.33,224 com.apple.launchd.peruser.501: (com.logmein.hamachimb) Throttling respawn: Will start in 10 seconds
08.11.11 20:29.33,226 com.apple.launchd.peruser.501: (com.vemedio.Snowtape.RadioAgent[43793]) posix_spawn("/Users/kaupo/Applications/Snowtape.app/Contents/MacOS/RadioAgent", ...): No such file or directory
08.11.11 20:29.33,227 com.apple.launchd.peruser.501: (com.vemedio.Snowtape.RadioAgent[43793]) Exited with code: 1
08.11.11 20:29.33,227 com.apple.launchd.peruser.501: (com.vemedio.Snowtape.RadioAgent) Throttling respawn: Will start in 10 seconds
08.11.11 20:29.35,904 [0x0-0x2d62d6].org.playonmac.playonmac: Exception TypeError: '
08.11.11 20:29.35,915 [0x0-0x2d62d6].org.playonmac.playonmac: join() takes exactly 2 arguments (1 given)' in <module 'threading' from '/Applications/PlayOnMac.app/Contents/Resources/lib/python2.7/threading.pyc'> ignored


This is basically what happened while i opened PlayOnMac.
Kuufi Tuesday 8 November 2011 at 19:34
KuufiAnonymous

And the error is basicly "PlayOnMac has encountered a fatal error, and will now terminate". I don't get more information . I can choose from terminate and Console.
Quentin PÂRIS Tuesday 8 November 2011 at 20:43
Quentin PÂRIS
Admin

Have you used PlayOnMac before or is it the first time you are running it ?
Kuufi Tuesday 8 November 2011 at 23:28
KuufiAnonymous

Well it was the first time i used it. Altho I've been using Winebottler earlier. But i removed that before installing PlayOnMac
Quentin PÂRIS Wednesday 9 November 2011 at 12:35
Quentin PÂRIS
Admin

Is there a PlayOnMac folder in library ?

Also, where is it installed ?
megacast Saturday 28 January 2012 at 12:02
megacastAnonymous

Hi! I get the same error as Kuufi. I've downloaded the latest version from the download page in your site, and I've also copied the file into 'Applications'. I have a Mac OS X version 10.6.8... graphic card NVIDIA GeForce 9400M : see any problem?
Thanks!