The forum

Mass Effect 2: Digital Deluxe Edition

Appears to be running, but nothing on screen

Author Replies
whyren Thursday 12 April 2012 at 3:28

I've been trying to get Mass Effect 2: Digital Deluxe Edition (via Amazon) working properly. For what it's worth, Mass Effect 1 is working fine.

Installation steps:
Ensure Adobe Air is installed in prefix
Run setup.exe from Mass Effect 2 - Digital Deluxe Edition (fails at EAAccessInstaller)
Run the following from command line from Mass Effect 2 - Digital Deluxe Edition\\software:
     EAAccessInstaller.exe /s /dir C:\\Program Files\\Mass Effect 2\\binaries

After that the launch seems to work fine (goes through the release date check without an AWC.dll error). Both launcher and config have no problems.

When I launch the actual game (via launcher or directly from the executable), both MassEffect2.exe and EACoreServer.exe appear in the task manager, along with (briefly) with activation.exe. After that though, nothing seems to happen. Both .exe are still showing in task manager, but nothing further happens (no messages, no errors, no black screen, etc.).

I've tried uninstalling/re-installing, installing into fresh wine-prefixes, manually calling the setup.exe, using the MassEffect2 install script with the setup.exe, patching to 1.0.2, switching wine versions to no avail. The one thing I have noticed (at least, in one prefix attempt) is that whenever I run the program, a folder is created in drive_c with no contents labeled { CP_Guest_xx(1)_ver3 } where xx is a 2 digit number.

I'm attempting a download from Origin to see if that works any better, but for whatever reason the download speed is maxing at about 15KB/sec (despite a 15Mbps connection) so it will be a while before I can confirm that.

Mac Pro
OS 10.6.8
2.66 Quad-Core Xeon