The forum

Diablo 2 download

Author Replies
ate62 Sunday 9 September 2012 at 2:31

Ok I have downloaded diablo 2 legally off blizzard i followed a youtube video's instructions on how to get it to work, I got it to work for a month or two but i went to play it a couple of weeks ago and it came up with and error. So I deleted D2 off my play on mac and tried to reinstall it but then i do now X11 has a fit and comes up with program error but gives me no information. I have downloaded playonmac the latest version so now i don't know what to do it still isn't working does this mean i have to re-download everything?
ate62 Sunday 9 September 2012 at 2:43

Oh and I got it to instal but when it went to the loading screen it was all static.
scoobydoo Sunday 23 September 2012 at 15:39

I'm faced with a similar problem.

I've just updated my mac's OSX to 10.7.5, and now my Diablo 2 LOD under PlayonMac doesn't work; it basically freezes after X11 launches. After installing PlayonMac 4.1.8 and updating X11 to XQuartz 2.7.3 as mentioned in the comments under the News section, I still can't get it to work.

I welcome any advise or fixes from the admin or users who have overcomed this problem.
Quentin PÂRIS Sunday 23 September 2012 at 15:52
Quentin PÂRISAnonymous

You have to update XQuartz to 2.7.4, not 2.7.3
scoobydoo Sunday 23 September 2012 at 16:11

Wow, it worked! My Diablo II LOD on PlayonMac lives once again. I'll recap a little on the steps I've taken to make this work.

1. Download & Install PlayonMac 4.1.8.
2. Download & Install XQuartz 2.7.4.
3. Reboot your computer.
4. Launch the Diablo II LOD just like before.
5. Play Diablo II LOD on PlayonMac.

Thank you very much for the assist. I'll send a donation for wonderful work you and your team have made. :)
Quentin PÂRIS Sunday 23 September 2012 at 16:14
Quentin PÂRISAnonymous

PlayOnMac 4.1.8 should install XQuartz 2.7.4 if everything goes well.
Deleted Out of topic
Maiko Wednesday 26 December 2012 at 19:06

I have a similar problem, for starters I just upgraded my Mac to Mountain Lion but even before I had problems using things like VMware and I'm not that tech savvy so I might have fucked something up? But when I try to install D2 it says we have encountered a serious problem with installer.exe and need to close. I have no idea on how to fix that in order to play? When that happens X11 pretty much crashes and I can't click or do anything with it
You are here: Index > PlayOnMac > Diablo 2 download