The forum

World of Warcraft : Mists of Pandaria

MoP Updated Script

Author Replies
Jump to the page: 1 - 2
d16174l4n63l Monday 1 October 2012 at 6:16

This is my first script any tips | changes | adjustments | cretiques welcome so long as they are constructive.

We have the old scripts still up think it might be time to have one for the new addenda of WoW.

if [ "$PLAYONLINUX" = "" ]
exit 0
source "$PLAYONLINUX/lib/sources"

TITLE="World of Warcraft : Mists of Pandaria"


POL_SetupWindow_presentation "World of Warcraft : Mists of Pandaria" "Activision / Blizzard Entertainment" "" "Silverman" "WorldOfWarcraft"

POL_Wine_SelectPrefix "WorldOfWarcraft"
POL_Wine_PrefixCreate "1.5.14"
POL_System_TmpCreate "WorldOfWarcaft"

POL_SetupWindow_InstallMethod "LOCAL"
cd "$HOME"
POL_SetupWindow_browse "Please select the installation file to run." "World-of-Warcraft-Setup-enUS.exe"
POL_SetupWindow_wait "Installing World of Warcraft : Mists of Pandaria." "World of Warcraft : Mists of Pandaria"
POL_Wine start /unix "$APP_ANSWER"


POL_Wine_WaitExit "$TITLE"
POL_Shortcut "World of Warcraft Launcher.exe" "" "World of Warcraft : Mists of Pandaria Launcher"
POL_Shortcut "Wow.exe" "$TITLE"

Zolex Wednesday 17 October 2012 at 21:54

Thank you very much for that script. It is working very well.
d16174l4n63l Thursday 18 October 2012 at 0:52

Glad to help, I am working on an expanded version that allows you to setup for opengl and directx. Do you have anything you would like to see out of the script, maybe a function?
sprice Monday 12 November 2012 at 23:59

So new to POL, used this script to "install" MOP. What I did was point it to the already installed Wow folder on a separate drive, but it errors out in POL when creating the shortcuts. I tried to modify the script to point it to the correct Launcher and correct Wow.exe, but no luck.

Any ideas?

Edit: Meant to add the errors:

Error in POL_Shortcut
Binary not found: /media/shared/World of Warcraft/World of Warcraft Launcher.exe
Have you installed the program to the default location?

Error in POL_Shortcut
Binary not found: /media/shared/World of Warcraft/Wow.exe
Have you installed the program to the default location?

The /media/shared/ is the path to the install

Edited by sprice

d16174l4n63l Wednesday 14 November 2012 at 17:40

let me make sure I understand whats going on and I have a couple questions.

So you already have an install you are using (/media/shared/) and when you used the script it will not create the proper shortcuts.
Does it create any shortcuts at all?
Is /media/shared/ your default PlayOnLinux area where it stores your program installs?

Quentin PÂRIS Thursday 15 November 2012 at 12:07
Quentin PÂRISAnonymous

So new to POL, used this script to "install" MOP. What I did was point it to the already installed Wow folder on a separate drive, but it errors out in POL when creating the shortcuts. 

Quote from sprice

That cannot work POL cannot guess what you are pointing. He is looking for a setup program
Syrinx Wednesday 21 November 2012 at 22:34

Getting back into Linux, and new to PoL. Glad I found it and this site.

d16174l4n63l: That script is amazing! Took advantage of WoW's Pandaria trial, and let your creation do its thing. I've never seen WoW run that well on Linux before!

With that, I do have a couple questions:
- After the install, I logged in to the game and played for a bit (to test). Logged out, and PoL is still running with Please wait while WoW: MoP is installed, and the loading circle just keeps going around and around. NEXT is grayed out, so I can only hit CANCEL. I'm guessing this is also why I have no WoW shortcuts?
EDIT: Figured out how to make shortcuts - 
CONFIGURE > choose your virtual drive, and then click on MAKE A NEW SHORTCUT FROM THIS VIRTUAL DRIVE > select the .exe from the list of icons.

- During the trailer, and the 'choose your realm/character' screen, the audio is very choppy and distorted. However, once you get into the game, it's fine. Is that a bug, or is there a fix?

Thank you again, for the script!

Edited by Syrinx

hyperfang8 Friday 23 November 2012 at 7:14

Hi i used :
cmd.exe /c pathtoexternalprogram
To trick POL and allow importing program.
You can look at my script here:

Avoid the Gates of Hell. Use
d16174l4n63l Saturday 24 November 2012 at 7:29

@Syrinx - Agent tends to be the villian in your first point. Worst case scenario once your install is done you can Tools -> Close All PlayOnLinux Software this should kickstart it up.

So far as the sound it's a case by case basis. Known bug as far as I know, and as I understand this is due to all the close ups and a suspicion that even though your character is created, WoW is still loading up the other styles behind the scenes.

Note: I can neither confirm nor deny that answer.

I should be done soon with my second iteration which allows people to make more choices on install, such as if they want to put up with the OpenGL mess or not, as some day they might actually fix it. 8)
Syrinx Friday 30 November 2012 at 16:20

d16174l4n63l: Thanks for your reply. I can live with the sound issue. Like I said, most of the time it gets reset (back to good), once I enter the game, or I do something to call a new sound, like talk to a NPC.

I do think I have one more issue though: low framerates. Like 4-8fps. I've been Googling a lot on this, and I keep seeing the OpenGL tag. Would your new script help with that, or am I way off base here?

I originally thought it was due to running Compiz, but I have done a fresh install of Linux Mint 13 (32 bit - MATE), and didn't install it this time around. My system specs are:
2x Pent. Dual-Core T4400 @ 2.20GHz
8gigs RAM

$ lspci -v | less
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
Subsystem: Toshiba America Info Systems Device ff1e
Flags: bus master, fast devsel, latency 0
Kernel driver in use: agpgart-intel

00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07) (prog-if 00 [VGA controller])
Subsystem: Toshiba America Info Systems Device ff11
Flags: bus master, fast devsel, latency 0, IRQ 45
Memory at d0000000 (64-bit, non-prefetchable) [size=4M]
Memory at c0000000 (64-bit, prefetchable) [size=256M]
I/O ports at 6110 [size=8]
Expansion ROM at [disabled]
Kernel driver in use: i915
Kernel modules: i915

00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
Subsystem: Toshiba America Info Systems Device ff11
Flags: bus master, fast devsel, latency 0
d16174l4n63l Friday 30 November 2012 at 16:42

That is the modification I have been working on, is giving the directx opengl choice.

Have you turned your graphics settings down?

Also try this
Click on your WOrld of Warcraft shortcut in the PlayOnLinux window -> select configure -> on the arguments box add


Start wow.

If that helps then we're on the right track. If not I have a few other things we can do to make it all work. Intel can be about as wacky as ATI at times with running wow. Just reply back and we'll keep working on it.
Syrinx Friday 30 November 2012 at 17:15

Added the -opengl tag like you have it there.

Running wine-1.5.14 Wow.exe -opengl (Working directory : /home/syrinx/.PlayOnLinux/wineprefix/WorldOfWarcraft/drive_c/Program Files/World of Warcraft)  
It doesn't like it. Log in, and as soon as I show up in my current city - FATAL EXCEPTION!

World of WarCraft: Retail Build (build 16309)

Exe: C:\\Program Files\\World of Warcraft\\Wow.exe
Time: Nov 30, 2012 11:10:43.286 AM
User: syrinx
Computer: Temples

This application has encountered a critical error:

ERROR #132 (0x85100084) Fatal exception!

Program: C:\\Program Files\\World of Warcraft\\Wow.exe
ProcessID: 8
Exception: 0xC0000005 (ACCESS_VIOLATION) at 0073:00000000

The instruction at "0x00000000" referenced memory at "0x00000000".
The memory could not be "read".

WoWBuild: 16309
Version: 5.1.0
Type: WoW
Platform: X86
Session Time(hh:mm:ss): 00:00:38
Time in World(hh:mm:ss): 00:00:20
Number of Char Logins: 1
Realm: Exodar (
Local Zone: Shattrath City (area id = 3703)
Local Player: Syrinx, 070000000005B0E3, (530, -1847.85, 5476.16, 0.856936)
Total lua memory: 17705KB
Current Addon: (null)
Current Addon function: UNKNOWN
Current Addon object: (null)

SET readTOS "1"
SET readEULA "1"
SET readScanning "-1"
SET readContest "-1"
SET locale "enUS"
SET showToolsUI "1"
SET accounttype "MP"
SET readTerminationWithoutNotice "-1"
SET installLocale "enUS"
SET enterWorld "1"
SET hwDetect "0"
SET videoOptionsVersion "5"
SET gxApi "OpenGL"
SET gxWindow "0"
SET gxMaximize "0"
SET accountList "!ODYSSEYSREALM|WoW1|"
SET mouseSpeed "1"
SET ChatMusicVolume "0.29999998211861"
SET ChatSoundVolume "0.39999997615814"
SET ChatAmbienceVolume "0.29999998211861"
SET VoiceActivationSensitivity "0.39999997615814"
SET Sound_MusicVolume "0.40000000596046"
SET Sound_AmbienceVolume "0.60000002384186"
SET farclip "200"
SET particleDensity "10"
SET environmentDetail "50"
SET textureFilteringMode "0"
SET terrainLodDist "200"
SET wmoLodDist "100"
SET terrainTextureLod "1"
SET terrainMipLevel "1"
SET worldBaseMip "2"
SET weatherDensity "0"
SET realmName "Exodar"
SET gameTip "17"

Also, when I looked at my FPS, they were at 4.

Also, I assumed it was your script settings, or PoL's - but yes, the graphic settings were already set to low. On my toon's cape, I can see the definitive lines between the color shades (as opposed to a fluid gradient). I hadn't touched anything in the setting menu.

Edited by Syrinx

d16174l4n63l Saturday 1 December 2012 at 16:03

okay, so we remove the -opengl from that box I talked about in my last post.

If you haven't done so already install Direct X 9

Highlight your WoW Icon -> Configure -> Install Packages tab -> select d3dx9 -> install

Once that is done start wow and see what happens.
Syrinx Friday 7 December 2012 at 14:53

Hey! So sorry it's taken forever to reply.

In the meantime, I did a complete uninstall/reinstall of PlayOnLinix, and using your script, re-downloaded/installed WoW:MoP.

Once that was done, I installed d3dx9

Logged in, made a test character* and I'm still at 4-7 fps.

*The face pics on the side were all a black silhouette, except for the glowing eyes (Undead).

Also, with the choppy/distorted sound issue - I've also noticed this when doing other things, like YouTube videos. The first few moments is all garbled, and then it's fine. Maybe something wrong in my sound settings?
joshuabeatdown Saturday 8 December 2012 at 20:40

I get to the installer, and it freezes at 0.0%. Any idea what to do?
d16174l4n63l Monday 10 December 2012 at 22:10

@Syrinx that may be a possibility so far as sound. I am looking into more performance issues that I can handle with the installer.

@joshuabeatdown the isntaller freezes or does it crash out?
SFaulken Wednesday 2 January 2013 at 21:35

Flat out fails for me, on BodhiLinux 2.0 (Based on Ubuntu 12.04), I have the dvd media mounted with "mount -o exec /dev/sr0 /media/cdrom" and after choosing the installer, it crashes with an error stating:

"Failed to extract required files from an archive. Please try again.

Please click the link below for more information or contact Customer Support if the problem persists.

Error code: BLZPTS00008"

The error code takes you to:

So what am I doing wrong, or what is broken here?
d16174l4n63l Wednesday 2 January 2013 at 21:50

That is strange, I've done the CD's and it worked well enough.

Though are you sudo mounting it.  Do the same command but start it with sudo, tell me the results.

SFaulken Wednesday 2 January 2013 at 22:02

sorry, I was using sudo to fire off the mount in the first place.

Same issue whether I attempt to install from a sudo mount, or a userspace mount
d16174l4n63l Monday 7 January 2013 at 16:05

alright, I will look into this as well 8)

Worst case the script does support the digital downloader from Bliz.

This site allows content generated by members, and we promptly remove any content that infringes copyright according to our Terms of Service. To report copyright infringement, please send a notice to