The forum Deponia -- Install Script

Author Replies
Jump to the page: 1 - 2
kweepeer Sunday 18 November 2012 at 18:58

I have made POL script for Deponia 1. I test it on my local machine, everything works fine here (cutscenes with sound etc).

Please test this (run as local script) if you have this game (GOG version), thanks.

Wine version: 1.4.1
Distribution: Ubuntu
Distribution version: 12.10
Graphics card: GTX 460
Graphics card driver: 304.64
Comments: Installation works fine & game runs beautifully in fullscreen with working cutscenes (no sound issues). Did not finish the game yet.

Edited by kweepeer

petch Sunday 18 November 2012 at 19:23

I don't have that game, but the script looks clean (strangely ;) ) and the game is rated Platinum on the AppDB, so I wouldn't expect bad surprises and I'm all for its addition to the official repository...
kweepeer Sunday 18 November 2012 at 20:47

Hi, I have submitted it. If you decide to add it, I have created some images. I did not know how to submit them.

Depona.png (icon):

Tell me if there's anything else I can do.
petch Sunday 18 November 2012 at 21:53

Ok, I validated the script, few changes:
- left image must be 150x356 pixels, not 150x365, I removed some blank at the bottom
- I set the script ID in the script: as soon as you're in the online form to edit the script you can see in the URL what ID the script will have
- I added the hash of the first download part to the "known md5 of setup files", so that if PlayOnLinux is started with this file as argument, it will start your install script. If GOG releases new versions of its installer, just add the new hash here
- I emptied the "tests" field, it's there to add unit tests in Bash (check that the files needed by the script can be downloaded, usually)
- I pushed your images, plus a 22x22 pixels downsampled icon for the installation script itself to the POL server

Last thing that can be done is to add some screenshots of the game, if you want :)
petch Sunday 18 November 2012 at 21:56

By the way is that the "real" icon of the game?
The point is that users immediately recognize the game from its icon...
kweepeer Sunday 18 November 2012 at 22:54

Thanks. I have noticed that in some later areas of the game, the game occasionally hangs for a few seconds. Still fully playable though. When I have more time I'll see if I can find a workaround for this.

It's not the real icon btw, here's the ico file maybe you can get a better icon out of it.

petch Sunday 18 November 2012 at 23:09

Mmmh GOG tends to rework icons too, so I don't know what is what... Oh well, let's keep current icon for now :)
hmdai Monday 19 November 2012 at 6:31

I have tried the script. Just like I have reported before (manual install), everything works fine except the video (no sound is heard when playing the video).

I'm using OpenSuSE 12.2 but I'm not sure whether I still miss out some requirements . :-(

The following is the output from debugger:

[11/19/12 13:26:52] - Running wine-1.4.1 Deponia.exe (Working directory : /home/hmdai/.PlayOnLinux/wineprefix/Deponia_gog/drive_c/GOG Games/Deponia)
fixme:keyboard:X11DRV_LoadKeyboardLayout L"00000409", 0080: stub!
fixme:keyboard:X11DRV_LoadKeyboardLayout L"00000409", 0001: stub!
err:ole:CoCreateInstance apartment not initialised
fixme:wgl:X11DRV_wglChoosePixelFormatARB unused pfAttribFList
fixme:wgl:X11DRV_wglChoosePixelFormatARB unused pfAttribFList
[theora @ 00149fe0] 7 bits left in packet 82
    Last message repeated 1 times
kweepeer Tuesday 20 November 2012 at 10:22

This report is also OpenSuSE 12.2 (maybe yours?) and confirms no sound in movies.

While for me and also this report on Ubuntu, the sound is working:

Maybe some things you can try:
1) Comments on winehq say something about /etc/pulse/ , check if you have a value tsched=0 ?

2) Try different wine versions, if you feel up to it. Backup your savegames, uninstall & try the script with different value on this line: WORKING_WINE_VERSION="1.4.1". I found 1.5.x gave me more choppy sound overall, so that's why I used 1.4.1. But maybe lower version can fix your sound issue.

3) Try different wine options. I don't know much about this yet, but there should be several options related to sound that can be changed. Is there a way to set audio Hardware Acceleration to Emulation ? I need to read up about those things, I'm not very experienced with wine...

In next script I will also try to add configurator, since I saw an exe in the game directory for configuring some options (not sure what exactly).
hmdai Wednesday 21 November 2012 at 3:16

I have already tried the following:

1. There is a file /etc/pulse/ but there is no such line exist.
2. I have tried with several different versions of WINE from 1.3.x to 1.5.x but still receive no sound from video.
3. The OSS emulation does exist in WINE v1.3.18 or before (It has been removed since v1.3.19). I have tried v1.3.18 and the issue still persist.

I just wonder whatever libraries which exist in Ubuntu which no in OpenSuSE default installation...
kweepeer Wednesday 21 November 2012 at 13:12

Hey, thanks for your testing, it's appreciated. I haven't had much time to look into it, to be honest. But I did find that the cutscenes are actually OGV files (Ogg Vorbis video).

Can you try to play them with VLC or so and see if you get sound?

I'm at work now so can't really verify, but they should be somewhere in:
~/.PlayOnLinux/wineprefix/Deponia_gog/drive_c/GOG Games/Deponia/videos

Just copy one of those to your homedir and rename it to *.ogv. Then try to play them with VLC or Totem.

PS: by any chance, do you have this game?

Because it's same engine (& same makers) so it could help us identify some issues we are having with Deponia.
hmdai Wednesday 21 November 2012 at 13:34

Hello, I have tried both VLC and mplayer to play the file directly (without extension renaming) and the videos can be played with sound.

I have missed the previous promotion so I haven't got the game >_
kweepeer Wednesday 21 November 2012 at 16:03

Ok, good. So your linux can play it fine, but wine can't play them with sound...

Can you try these scripts and see if one works for you:

I haven't tested them so they could just fail. But it's worth a try... :)
hmdai Thursday 22 November 2012 at 7:14

Eventually I have found out the issue. It is not related to POL and the current script is fine. It is related to wine and SDL.

I have found the solution in WINE wiki:

In session "SDL applications", it has mentioned the following:

The Windows SDL library contains support for several audio backends, such as "winmm" and "dsound". If the SDL_AUDIODRIVER environment variable is set, then SDL loads the matching backend, or fails if the backend isn't available.

Since SDL is a cross-platform library, it has this same functionality on Linux. Accordingly, some Linux distributions' SDL package will set the SDL_AUDIODRIVER environment variable to match the Linux backend, so that SDL-using Linux applications will use the appropriate backend (e.g. "pulse").

But this creates problems for SDL applications run in Wine. The Windows SDL library loads the Linux SDL_AUDIODRIVER environment variable, which contains "pulse" or some other invalid backend for the Windows SDL library, and so audio fails to initialize in SDL-using Windows applications run through Wine.

The solution here is to unset your SDL_AUDIODRIVER environment variable before running Wine. This should restore your audio, as SDL will fall back on one of its default Windows drivers. Alternatively, you can create a new registry entry which will override the SDL_AUDIODRIVER environment variable for your Wine prefix:

[HKLM\\System\\CurrentControlSet\\Control\\Session Manager\\Environment] SDL_AUDIODRIVER=""

After I have set the registry entry, the video can play with sound! :) The only draw back is the video which showing company name will become slow and unable to show the main screen after finished. The workaround is press "Esc" and the main menu can be shown without any problem. It seems like Ubuntu has already include the patch to cater for this issue while OpenSuSE doesn't.

Anyway, have you encountered the save problem? I cannot make a save but the game does have a "Continue" button which can resume the game to the current progress. You just can't save and go back to a particular point.

hmdai Thursday 22 November 2012 at 7:37

Oh, ignore the "Daedric" video slowness issue. It is cause by one of my trial-n-error afford to resolve the issue. After I have restored the change made, the video can be played without any slowness and the main menu can be shown.
kweepeer Thursday 22 November 2012 at 10:33

Awesome, thanks for your hard work :) In time I think we will make the game run perfectly! It will be a good foundation for Deponia 2 & 3 and other games that are made with Visionaire Studio. I would like to add your fix for sound to the script, as to provide a script that works for as many people as possible, without having to manually configure things afterwards.

Perhaps petch or another dev can advise on how to best set this registry key from within the script (maybe a function already exists?).

Now, 2 issues remain it seems:
- Can't save: For me it works fine out of the box, I can save/load/continue.
- On changing zones later in the game, sometimes the game freezes for a few seconds. After a while, the freezes can be longer than before. I need to do some testing on what exactly causes this. I'll have more time in weekend to look into this.
kweepeer Thursday 22 November 2012 at 18:54

Savegame problem:

Can you try to save & then check messages.log for the error.

In this folder: ~/PlayOnLinux's virtual drives/Deponia_gog/drive_c/users/hmdai/Local Settings/Application Data/Daedalic Entertainment/Deponia/messages.log
hmdai Friday 23 November 2012 at 9:11

Yes. I have just found this solution as well :)

After I have created a "tmp" folder under the path:

PlayOnLinux's virtual drives/Deponia_gog/drive_c

The game can be saved and loaded successfully! Horay!
petch Friday 23 November 2012 at 9:41

Aha. It's probably a problem similar to the ALSA one, it may be picking some Unix environment variables that says that temporary files should be created in /tmp...
hmdai Saturday 24 November 2012 at 18:08

Hi Kweepeer,

I think you could add the following code into the script between POL_SetupWindow_Close and exit for registry edit create tmp folder.

# Add registry entry to override the value of environment variable SDL_AUDIODRIVER in Linux
cat << 'EOF' > "$DIRECTORY/tmp/deponia.reg"
[HKEY_LOCAL_MACHINE\\System\\CurrentControlSet\\Control\\Session Manager\\Environment]
POL_Wine regedit "$DIRECTORY/tmp/deponia.reg"

# Create a tmp directory for the game to create thumbnail image for save game
cd "$WINEPREFIX/drive_c/"
mkdir "tmp"

This site allows content generated by members, and we promptly remove any content that infringes copyright according to our Terms of Service. To report copyright infringement, please send a notice to