Forums

League of Legends - Red icons in game item shop fix

Using lol-linux --- With Python3.3

Auteur Réponses
SuperDanceParty Lundi 23 September 2013 à 22:49
SuperDancePartyAnonymous

This is my guide on how to run the lol_linux.py script properly.  The problem here is that the developer who made this script didn't set the program to automatically use python3.3, but rather python2.7.  The old python language uses different syntax, and for a lot of people who tried running the script without reading every inch of the readme file included, they ended up with various bugs in the game afterwards (like massive shop icons that reach outside their boundaries in game).

Step One: Downloading the python program

(Original link to developer's page for reference:  https://github.com/A-Metaphysical-Drama/LoL-Linux-Tools)

Open a terminal window, and keep it open, we'll be working in this window for most of the installation process.

First we need to change directory to the folder you want to download the script to.  Put it somewhere safe that you can easily find it again, since you need to run this script again, every time Riot Games patch League of Legends, or the red icon glitch will come back.

Next, we download the python scripts directly from the developers github.

[code=console]
cd /home/alex/Downloads/
git clone git://github.com/A-Metaphysical-Drama/LoL-Linux-Tools.git
[/code]

Step Two: Configuring the config.py script to locate your League of Legends directory

Next navigate to the file 'config.py' in the folder you just downloaded.  I suggest using a file manager to locate the file, then display it's contents with something like gedit.

Once you open it, notice near the bottom of the script the line 'lol_path = '/path/otherpath/morepath/'  The /path in there by default is arbitrary.

Change the path to the League of Legends directory, use a true directory and make sure it's the same destination folder that contains the RADS folder.  On my computer this line would read:

lol_path = '$HOME/.PlayOnLinux/wineprefix/LeagueOfLegends/drive_c/Riot Games/League of Legends'

It's OK to have spaces in the name, in fact if you try anything fancy like '/Riot\ Games/League\ of\ Legends/' the script will fail.

Step Three: Do you have python3.3 installed?

If you have python3.3 installed, skip to the next step.  If you're not sure, run this in A NEW terminal window

[code=console]
python3.3
[/code]

If python 3.3 is installed you should get this returned to you, and you can skip the rest of this step and move on to step four.  You can close that new terminal window now, we were only using it to test if python3.3 is installed.

[code=console]
Python 3.3.1 (default, Jul  5 2013, 09:19:20)
[GCC 4.7.3] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>>
[/code]

If it's not installed you will get an error.  Proceed with the rest of the instructions in this step.  By the way, you can close that new terminal window now, we were only using it to test if python3.3 is installed.

The python program we downloaded requires you have python3.3 installed, but doesn't use it by default.  Playonlinux also doesn't require you install python3.3 to run it, but most distributions of linux have it installed by default.  If you don't, try using this in your terminal window

[code=console]
sudo apt-get install python3.3
[/code]

Step Four: Running the script.

This is the final step.  It takes a few minutes to run it's course, so once you start the program, just let it run it's course.

Before running the script though, make sure you navigate to the folder where you downloaded the scripts to earlier.  In my case this would be:

[code=console]
cd $HOME/Downloads/lol-linux-tools
[/code]

Ok, now run the script using this command:

[code=console]
python3.3 lol_linux.py texture_patch
[/code]

## What did we just run?  The first command tells linux to use the python3.3 interpreter.  The second command tells python3.3 to open the file 'lol_linux.py'.  The last command tells lol_linux.py to use the texture_patch parameter, which is curently the only working function the developer has implemented.  There are a few other features he plans to implement in the future, but until then, this is your only option.

Ok, I know I write a lot, but I wanted to make sure everyone understands what they're doing, why they're doing it and why there are to threads on the forum about the same topic.

Please, reply to this thread with your success/horror stories using my walkthrough.

NOTE:  If you have any questions like "what is python" or "how do I know what folder League of Legends is installed in?" try googling and finding out for yourself first.  If it takes an hour that's fine.  I'd rather you spent an hour googling, than I spent an hour doing it for you.
booman Mardi 24 September 2013 à 1:44
booman

Very nice tutorial!
Thanks for posting. I have copied the address so I can refer to it later when people ask about the icons and store crashing.

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
SuperDanceParty Mardi 24 September 2013 à 2:21
SuperDancePartyAnonymous

Thanks. If the dev wrote the program to work with 3.3 automatically it wouldnt be like this ;) haha. I'm still just learning python, so every attempt I made to fix the package or customize it for you guys ended up with me breaking it a bit, just cause the program was only built to function in a certain way. Oh well, one day I'll be a pro.
booman Mardi 24 September 2013 à 5:35
booman

Breaking things is how I learn, so keep at it... don't give up!

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
SuperDanceParty Mardi 24 September 2013 à 8:00
SuperDancePartyAnonymous

Haha, yeah but I'm busy studying for the LPI. And the nature of the bugs... I know how to fix them, and python tells you EXACTLY where they are too, which is great, but I just don't have the time.
booman Mardi 24 September 2013 à 16:20
booman

I know what you mean. I was thinking of learning python to do some game design, but its on of those "things" where you have to do it every day. Otherwise you forget.

Right now my focus is testing games in Linux. I've put aside game design for now and am working on boosting the game popularity for Linux and I'm having a lot of success.

Hence why I'm on the forum here...

All in good time

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
SuperDanceParty Mardi 24 September 2013 à 21:30
SuperDancePartyAnonymous

Heh. I would love to dive into a conversation about that, but it would get off topic really fast.
petch Mercredi 25 September 2013 à 0:32
petch
Développeur

...
Unpacking Archives, please wait...
Saving Backups, please wait...
Replacing Files, please wait...
Repacking Archives, please wait...
Checking New Archives, please wait...
./temp/texture_patch/filearchives/0.0.0.25/Archive_124004400.raf size does not match the original one!


By the way there has been a new commit to the git repository last monday
SuperDanceParty Mercredi 25 September 2013 à 1:22
SuperDancePartyAnonymous

I was just looking at that and noticed that too. I'm sure that your file not matching the original size is because you already ran the app once with python2.7. If you navigate to the folder you downloaded the script with there is some backup files there. Not too sure how well they work though.

I told someone else already, that if you've broken it with 2.7, you should reinstall the game first, then try again with 3.3. I had to reinstall a few times before I found this method.

EDIT:

I looked at the changes.  All he did was add extra functionality to the extraction process (regarding the icons you download from him when you run the script), probably to improve stability.  And made the texture_patch function a little bit smarter. 

Edité par SuperDanceParty

petch Mercredi 25 September 2013 à 1:29
petch
Développeur

I followed the instructions exactly: reinstalled LoL from scratch, ran the patch with Python 3.3
SuperDanceParty Mercredi 25 September 2013 à 1:38
SuperDancePartyAnonymous

Oh really? Try posting as an issue with the developer on his git page. I don't know enough about the program to help you any more. :(
Tibbus Vendredi 1 Novembre 2013 à 1:05
TibbusAnonymous

Worked for me, fast and smooth, no more red icons, Ubuntu 13.10 64b
rocki123 Samedi 21 Décembre 2013 à 5:19
rocki123Anonymous

I used script with python 3.3.2 on linux mint 16 and when i try start lol it has very big icons and font which i cant click correctly.
Btw. does anyone know fix for sound ingame or champion shop?
llleeegend304 Jeudi 9 Janvier 2014 à 10:18
llleeegend304Anonymous

Mines having problems unpacking archive.. well, I couldn't exactly handle the busted item shop menu. Any advice?

+ In addition, its saying Removed to most Icons2D/.dds, only a few have patched (namely blade of ruined king, blackfire torch, frozen fists, etc. which are map specific?)

Edité par llleeegend304

llleeegend304 Jeudi 9 Janvier 2014 à 10:51
llleeegend304Anonymous

Oh! 3RD times a charm! the installer finished.
now to test.
llleeegend304 Jeudi 9 Janvier 2014 à 11:07
llleeegend304Anonymous

Ok, this script got the Icons set proper! now to make icon sizes/text sync to the actual menu buttons
llleeegend304 Dimanche 12 Janvier 2014 à 1:27
llleeegend304Anonymous

Yeah an update on the situation, the huge ITEMSHOP fonts-icons issue isn't present when playing on Summoners Rift, everything functions normal on Summoners rift, but not Howling Abyss(ARAM).. could someone point me in the direction to fixing this?

By the way, sweet icon texture fix! much appreciation from my way.
llleeegend304 Dimanche 12 Janvier 2014 à 1:38
llleeegend304Anonymous

-- and for the record, I've broke Ubuntu already once (and LoL several times) in the past week trying to remedy the ARAM Weapon+Item-Shop and change my screen settings.. alternatively today and last night I've just been learning my Equipment build.. (with Master Yi I just pick up a Statikk Shiv and Infinity Edges lol.)

being able to patch up the ARAM Weapon Shop would be sweet-- although I'm hardly concerned with getting high-res, so long as I get frames and somewhat complete functionality.
AFDC98 Dimanche 16 Février 2014 à 23:23
AFDC98Anonymous

Great work! :) Works perfectly for me... but when I open the lol.launcher.exe again, it appears something like "Your data may be corrupted, would you like to repair it?". So it doesn't let me play until the launcher fixes the patched files, so the item shop problem repeats. I don't know how to avoid this message, any tips?

PD.: Sorry, I can't get what the message literally says 'cause it's my own translation from spanish.