Having a strange problem with wineasio and Ableton

Works only via "wine /path/to/exe" in POL shell

Auteur Réponses
overdrivenpotato Mardi 25 Mars 2014 à 22:43


I've run into a bit of a strange problem recently while trying to get Ableton Live 9.1 32-bit to work with wineasio. Every time I select "WineASIO Driver" as a driver in Ableton's preferences, it responds with "Failed to open the audio device 'WineASIO Driver'" ( Here's the debug log:
Just to make sure it wasn't an issue on my end, I deleted my wineprefix and installed ableton fresh, along with wineasio from POL's configure>install components menu and it gives the same error. The strange part is that if I run Ableton via "Open a shell" and by running "wine ./path/to/Ableton Live 9 Suite.exe", wineasio works perfectly and Ableton is completely usable.
If anybody has any sort of fix for this, that would be amazing.

Extra info:
  • Soundcard is Scarlett 18i6
  • jackdmp version 1.9.10 tmpdir /dev/shm protocol 8
  • 'wine --version' in POL shell gives me wine-1.7.14
  • Error pops up with both wine 1.7.15 selected in POL and default 1.5.25
  • 'which wine' shows wine points to /usr/bin/wine