Sudden catastrophe

LoL and Stream both broke

Auteur Réponses
jadbox Jeudi 13 Novembre 2014 à 6:17

I recently did a system update (regular apt-get) and now playonlinux is behaving oddly.

  • When I try to run League of Legends, a tiny gray square shows up.
  • When I click to "configure wine" under Configure, the same tiny square appears. When I force the "tiny square" window to be maximized, I see a window with no controls in it.
  • When starting steam now, there's no text in the login screen... was working fine before this all happened.
  • With all of the above, switching wine versions (1.6.2, system, 1.7.30, etc) did not change the problem.
  • Unfortunately, I lost the log of the apt-get dist-update that caused the issue, except that the kernel headers were upgraded to 3.16.0-4-amd64.
  • Native Steam on Linux works fine: no text or game issues.

System: Debian Jessie
Nvidia drivers: 343.22
Direct rendering: yes
Shell: Both Cinnamon and XFCE did not make a difference for this problem.
Kernel: 3.16.0-4-amd64

Any thoughts?

Edité par jadbox

izberion Samedi 15 Novembre 2014 à 7:34

My graphics drivers always behave weird after a kernel update. By that I mean not at all. KDE doesn't even start. If you haven't reinstalled your drivers since updating, try that.

By the way, how is your fps in LoL after a little while. I don't know what you have for system specs, but I'm running a Nvidia card (GTX 770) and 16 GB RAM on Debian Jessie and my fps tanks to between 20-30 after about 5 minutes in game. Every other game I run at max 60fps 1080p :P

Ronin DUSETTE Samedi 15 Novembre 2014 à 8:31

Really, whenever I update my system and there are kernel updates involved, I reboot the system, reinstall my proprietary drivers (in my case, Nvidia drivers on kubuntu 14.04 64 bit) with:

sudo nvidia-installer --update -f

(NOTE*: I know that AMD has options to do something just like this.)

and, of course when asked, I choose to install the 32-bit drivers. The AMD drivers do the same. 

Basically, the module needs to be recompiled for the current kernel, but another thing (which is far more common, in my experience) is the libgl libraries getting updated with the open-source ones, which won't work with the proprietary driver modules (they share the same namespace). So when reinstalling the drivers, it is also replacing the open-source opengl libs with ones from the proprietary graphics installer, which are compatible with the Nvidia kernel module.

Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
izberion Samedi 15 Novembre 2014 à 8:44

By the way, 'smxi' is handy for dealing with kernel stuff and 'sgfxi' will install nvidia drivers for you

jadbox Samedi 15 Novembre 2014 à 19:59

I guess it was just a font issue, it was fixed with:

apt-get install libfreetype6:i386

I have no idea why I suddenly needed this package (or lost it).

Ronin DUSETTE Dimanche 16 Novembre 2014 à 2:22

Some applications require it. It is just how Wine works. If it worked before, it was likely removed with uninstalling a package or some other action (maybe you ran sudo apt-get autoclean or sudo apt-get autoremove or something).

Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Vous êtes ici: Index > PlayOnLinux > Sudden catastrophe