Forums

I'm trying to alter a script to use 64 bit WINE

Auteur Réponses
guises Samedi 7 Mars 2015 à 3:28
guisesAnonymous

So I'm trying to install the 64 bit version of Unity3D, folling the instructions on this page:

http://wiki.unity3d.com/index.php/Running_Unity_on_Linux_through_Wine

In particular, that means using the script below. I've modified the script only to change the version of WINE to the most recent (per the instructions) and to comment out the WINEARCH="win32" line, which I had thought would give me the 64 bit version by default. That doesn't seem to be happening though. Could someone tell me where I'm going wrong?

 

#!/bin/bash

# Date : (2014-03-07 10-21)
# Last revision : (2014-03-07 10-21)
# Wine version used : 1.7.21
# Distribution used to test : OpenSuse 13.1
# Authors : waneck-six, Damian-LinuxFan, Tomza (pogtoma@gmail.com), gnumaru, Doctor Jellyface (doctorjellyface@riseup.net)
# Contributors: Goran Grncaroski (running MonoDevelop), eje211 (crash fix), other people (testing solutions)
# Script licence : GPL v.2
# Only For : http://www.playonmac.com
# Depend :

# Known Issues : You can't use Asset Store

[ "$PLAYONLINUX" = "" ]  exit 0
source "$PLAYONLINUX/lib/sources"

TITLE="Unity 3D"
PREFIX="Unity3D"64
WINE_VERSION="1.7.38"

POL_SetupWindow_Init
POL_Debug_Init

POL_SetupWindow_presentation "$TITLE" "Unity" "http://www.unity3d.com/" "Cauê Waneck, Damian-LinuxFan, Tomasz Zackiewicz, gnumaru, Doctor Jellyface" "$PREFIX"

#create prefix
#export WINEARCH="win32"
POL_Wine_SelectPrefix "$PREFIX"
POL_Wine_PrefixCreate "$WINE_VERSION"

#setup prefix
POL_Wine_InstallFonts
POL_Call POL_Install_directx9
POL_Call POL_Install_dotnet20
POL_Call POL_Install_dotnet35
POL_Call POL_Install_dotnet40
POL_Call POL_Install_tahoma
POL_Call POL_Install_vcrun2008
POL_Call POL_Install_vcrun2010
POL_Call POL_Install_mono210
POL_Call POL_Install_d3dx9_36
POL_Call POL_Install_d3dcompiler_43
POL_Call POL_Install_dxdiag
POL_Call POL_Install_dxfullsetup
POL_Call POL_Install_physx
POL_Call POL_Install_corefonts
POL_Call POL_Install_msxml6
POL_Call POL_Install_wininet
POL_Call POL_Install_ie8

#Setting OS wer
Set_OS  "winxp" "sp3"

#Setting mono forcing in MonoDevelop
POL_Wine_OverrideDLL "native, builtin" "mscore"
POL_Wine_OverrideDLL "builtin, native" "dnsapi"
POL_Wine_OverrideDLL "" "mscorsvw.exe"

mkdir -p $WINEPREFIX/drive_c/users/$USER/AppData/LocalLow

#registry
POL_Wine reg add "HKLM\Software\Microsoft\Windows NT\CurrentVersion" /v ProductId /t REG_SZ /d 12345-oem-0000001-54321

POL_SetupWindow_browse "Please select the location of the Unity3D setup executable" "$TITLE"

UNITYLOC=$APP_ANSWER
POL_Wine $UNITYLOC

POL_Shortcut "Unity.exe" "$TITLE"

POL_SetupWindow_Close
exit

 

petch Samedi 7 Mars 2015 à 7:17
petch
Développeur

Use POL_System_SetArch "amd64"

However,

POL_Call POL_Install_dotnet20

POL_Call POL_Install_dotnet35

POL_Call POL_Install_dotnet40

POL_Call POL_Install_msxml6

POL_Call POL_Install_ie8

at least, do not work in 64bit virtual drives.

guises Samedi 7 Mars 2015 à 9:17
guisesAnonymous

Ah, dang. I don't think those are optional, I guess I'm stuck with the 32 bit version then. Thanks.