Fonts antialiasing in El Capitan

Works from PlayOnMac, doesn't when run from the desktop "link"

Auteur Réponses
Fantomas.CZ Dimanche 31 Janvier 2016 à 15:56

Hi, I have a peculiar problem: I'm trying to get antialiased fonts. When I start a program from PlayOnMac program, antialiasing works and the fonts look nice. However when I run it using the desktop shortcut, which I made from that very same PlayOnMac program, antialiasing is lost. No matter if running a windows program, registry editor, whatever, it always "works" like this.

I find it quite strange, but I would like to have antialiasing all the time.

I have a late 2012 iMac on El Capitan, when using wine or CrossOver, antialiasing is not working either. On PlayOnMac I installed wine 1.8 and 1.9.2 and it works on both of them, but only when I run it from the program.

Thanks for any help!

fuzunspm Mardi 9 Février 2016 à 12:04

same problem here. Running from desktop icon also ignores .exe arguments

norealm Lundi 26 Mars 2018 à 10:06

After manually compared the environment variables of app launched from shortcut and PlayOnMac program, I found that shortcut launched app missing lots of variables.

Add following line to playonmac script under the .app shortcut folder seems to fix the problem.

export WRITE_LD="$PLAYONLINUX/../unix/image_magick/lib:$PLAYONLINUX/../unix/tools/lib/ld:/opt/X11/lib/:"

But it's strange that only one of my Macs has this problem.

Edité par norealm