Problems installing Max Payne

Wine-Version is not changeable after installation

Auteur Réponses
MaxKraft Jeudi 23 Février 2017 à 23:01

Hi all,


I'm having some trouble with the installation of Max Payne on ubuntu 16.04 LTS and PlayOnLinux 4.2.10. The Setup is working fine, after the installation I can see the welcome-screen of Max Payne. I close it and choose "End" at assisstant and the assistant says:

Error in POL_Shortcut_GetPrefix
Shortcut does not exist

Ok, nevermind, I can create the shortcut by myself. I go to "Configure" where I can see the drive of "MaxPayne" and I can create a Starter. BUT: Whenever I change the wine-version from "System" to "1.1.43" it will be changed back to "System" when returning to the configuration screen.

And when I try to start Max Payne the Max Payne start screen opens (where I can chosse Screen Mode and Acceleration and things like that). After pressing "Play" the screen freezes and I have to kill the application. In the error log I can ssee that wine version 2.2 is used:

[02/23/17 22:36:44] - Running wine- MaxPayne.exe (Working directory : /home/michael/.PlayOnLinux/wineprefix/MaxPayne/drive_c/Program Files (x86)/Max Payne)
fixme:winediag:start_process Wine Staging 2.2 is a testing version containing experimental patches.
fixme:winediag:start_process Please mention your exact version when filing bug reports on

I know that Max Payne will not start with wine 2.2 and that's why I want to change the version. But why does the change doesn't have an effect? Furthermore I wanted to check the config-file, but there is no playonlinux.cfg in the game directory (.PlayOnLinux/wineprefix/MaxPayne), only the playonlinux.log

Can anyone help?

MaxKraft Vendredi 24 Février 2017 à 22:44

Finally I tried this script:

And it worked, the config file playonlinux.cfg has been created. Now I am able to select the different versions of wine.

Strange. But no time to think about it cause I have to play!