DirectX installed, but Source running in DX6.0 mode.

Auteur Réponses
RB Lundi 19 Mai 2008 à 19:23

Hi all,

I've installed PlayOnLinux and love it, but I'm having a problem. I've installed Steam, with Counter Strike : Source and, while I can play it, it seems to be running in DirectX 6.0 mode. I've installed DirectX in POL (by clicking Tools->Install DirectX) for Steam, but when I run CS:S
and click "Options" -> "Video" -> "Advanced" it reads :

Hardware DirectX Level : v6.0
Software DirectX Level : v9.0

How do I make it so the Hardware DirectX Level is also 9.0 (my card is def. 9.0 capable!).

Many thanks,


==== Technical Details ====

Wine Version : 0.9.61
PlayOnLinux Version : 2.7.2
Distribution : Hardy Heron 8.04.
Kernel : 2.6.24-16-generic
Graphics Card : Gigabyte GF 8800GT 512MB.
CPU : Core 2 Duo E6300
GNU_Raziel Mardi 20 Mai 2008 à 10:17

If you want to force a DirectX level, go in "Shortcut Options" of your game in Steam and add : -dxlevel 90
RB Mardi 20 Mai 2008 à 22:46

That's ace - solved my problem perfectly. DX 9 is a little slow (30fps) but DX 8 gives 50->60 fps :-)

Thanks very much.