no sound in Pol - Mint 18

Auteur Réponses
Janus12th Samedi 29 Décembre 2018 à 18:57

i have raised this issue before but this seems to be an ongoing thing with each distro

i have switched from mint 17.3 to 18.3 , and in doing so i now get no sound from pol , im using jack but even without jack running there is no sound from pol , if i create say a new drive using system and go into wine the audio interface is not even recognised so when testing sound nothing happens - it doesnt even show up in Pavucontrol , however i do have system sounds on linux runnng through jack so i dont think its jack thats the problem.

any help would be appreciated

Thank You

Edité par Janus12th

Quentin PÂRIS Samedi 29 Décembre 2018 à 19:28
Quentin PÂRISAnonymous

Can you show me the logs in your terminal please?

Janus12th Samedi 29 Décembre 2018 à 19:32

hi quentin 

tell me what i need to do and ill be happy to supply whats needed 



Quentin PÂRIS Samedi 29 Décembre 2018 à 21:05
Quentin PÂRISAnonymous

Just run PlayOnLinux from a terminal, and copy and paste what happens here

Janus12th Dimanche 30 Décembre 2018 à 8:53

Hi Quentin - info as requested - Thanks

all i did was run Pol - access the drive i created , went into wine and tested sound

Looking for python... 2.7.12 - wxversion(s): 3.0-gtk2
[main] Message: PlayOnLinux (4.2.10) is starting
[clean_tmp] Message: Cleaning temp directory
[Check_OpenGL] Warning: check_dd_x86 missing, test skipped
[Check_OpenGL] Warning: check_dd_amd64 missing, test skipped
[POL_System_CheckFS] Message: Checking filesystem for /home/janus12th/.PlayOnLinux/
[main] Message: Filesystem is compatible
[install_plugins] Message: Checking plug-in: ScreenCap...
[install_plugins] Message: Checking plug-in: PlayOnLinux Vault...
[update_check] Message: List is up to date
[POL_SetupWindow_Init] Message: Creating new window for pid 4967
[POL_SetupWindow_Close] Message: Closing window for pid 4967
[POL_Wine] Message: Running wine- winecfg (Working directory : /usr/share/playonlinux/python)
[POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See
err:module:load_builtin_dll failed to load .so lib for builtin L"winepulse.drv": cannot open shared object file: No such file or directory
ALSA lib conf.c:3357:(snd_config_hooks_call) Cannot open shared library
ALSA lib pcm.c:2266:(snd_pcm_open_noupdate) Unknown PCM default
ALSA lib pcm_dsnoop.c:606:(snd_pcm_dsnoop_open) unable to open slave
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
[POL_Wine] Message: Wine return: 0
Registered PID: 4710 (Missing)
Registered PID: 4748 (Missing)
Registered PID: 4967 (Present)

Edité par Janus12th

Janus12th Dimanche 30 Décembre 2018 à 9:23

i have installed all codecs and the sytem is up to date

Quentin PÂRIS Dimanche 30 Décembre 2018 à 13:03
Quentin PÂRISAnonymous

Please try to updat PlayOnLinux to 4.3.4, redownload your wine version and tell me if it is better

Janus12th Dimanche 30 Décembre 2018 à 14:29

Downloaded and installed 4.3.4 and reinstalled wine1.6 the only other thing was pol asked for jq & libonig2 to be installed also

created new drive within Pol and yes it appears to now see the usb dac but still no audio , i still have sytem audio



Update - i rebooted and when i went back the audio came through so i proceeded setting up things , now the issue is vcrun2008sp1 x86 wont install in just hangs and hangs and doesnt do anything - eventually i have to cancel this is creating a new drive and not the one where the audio worked


after i rebooted and it worked i then installed qjackctl and set it to run on startup, then rebooted again and jack is running , the problem is with jack running the audio device is now not recognised within wine so back to square one

Edité par Janus12th

Quentin PÂRIS Dimanche 30 Décembre 2018 à 16:03
Quentin PÂRISAnonymous

Try a most recent version of wine, like 4.x

Janus12th Dimanche 30 Décembre 2018 à 16:14

4.x am i missing something did you mean 1.4 ?

i dont see a 4.x in the repo

Edité par Janus12th

Quentin PÂRIS Dimanche 30 Décembre 2018 à 16:19
Quentin PÂRISAnonymous

I mean wine 4.x

Janus12th Dimanche 30 Décembre 2018 à 16:42

i can only see 3.04 on the web which is stable so i installed that , but Pol doesnt recognise it and says install wine to use pol

i unistalled it and put back the 1.6 from the repo and now when i go into wine / configure wine as the output device it now gives me only system default and pulseaudio - when i select pulseaudio the audio comes through jack

however if i create a new drive and go into wine / config wine / pulse audio is not an option and the usb dac is not listed either


god knows how i got there , by accident i suppose , i think linux mint 18 is just broke , 17.3 worked fine 18.3 just seem problamatic

Edité par Janus12th