AOE2 Mac Big Sur 11.1

Auteur Réponses
pda__ Vendredi 25 Décembre 2020 à 10:53


Hi everyone, 

I am trying to play AOE2: Definitive Edition through playonmac using new mac OS Big Sur 11.1. I have read through several forums, including this one, and can't find a solution for my problem. 

After installing steam on playonmac and launching it, I encourtered the black screen error - i.e. couldn't download the game. 'wine steam.exe -no-browser +open steam://open/minigameslist' fixed this for me by opening 'small mode' and the game downloaded fine.

I then try to open it and click play and it starts but nothing happens. I've read that I need to ensure my wineskin version is 2.12 but I can't find this file to configure anywhere in my applications folder (wineskin was auto-installed during the playonmac steam installation).

I've also tried to configure the wine version in playonmac by pressing on steam -> configure -> wine version + button but under the x86 and amd64 versions it is just blank so I can't do anything there...

I read another solution was to right-click on the game and go to properties -> local files -> browse local files -> rename AoK.eve to launcher.exe (and rename original file). My issue is that, in the steam 'small mode' when I right click on the game and click on properties, nothing happens. I.e. I can't get into any menu to change these file names. 

I'm therefore left with the game downloaded and visible in the steam small mode but when I click play, nothing happens. 

Does anyone have a solution? 

Thanks very much in advance, 






chunganator Dimanche 27 Décembre 2020 à 0:28

I was under the impression that Aoe2 DE isnt supported yet for Play on Mac

sosss12 Mardi 29 Décembre 2020 à 22:11


Fyi I have exactly the same issues - wine version has only 'System' as options and more annoyingly the 'Properties' tab leads nowhere (simply running AoE doesn't do it of course). I've tried with a VBox VM lately but I get a graphics issue - I think our best bet for now (if you don't use Parallels Desktop/Crossover which require a subscription) is to access the properties through source...But I have to look into that - it's been fairly tiring to get it working...