Starting 64-bit process not supported in 32-bit virtual drives

Auteur Réponses
gibbsjj Mercredi 9 Mars 2022 à 7:48


I'm having trouble with POM.

Computer: MBP 14" M1 Pro running Monterey 12.2.1
POM: 4.4.3


I installed a very simple 64-bit windows program using the 'Install a non-listed program' option. For the virtual drive, I selected the '64-bits Windows Installation' option. This works perfectly and I am able to successfully install the program. The program installer has an option to 'launch now' once the install is done, and if I select this option the program starts and runs perfectly.


Once the install is done and I try to start the program I get the following error:

Error in POL_Wine
Starting 64-bit process FastLogEntry.exe is not supported in 32-bit virtual drives


I have tried uninstalling and reinstalling (deleting the virtual drive each time) several times with the same result. This seems like a bug since I choose the '64-bits Windows Installation' option during installation. Why does it say I have a 32-bit virtual drive? The only way I can get my 'FastLogEntry.exe' program to work now is to remove it and reinstall it / select the 'launch now' option from the program's installer. Once I exit the program, it will not run again and throws the above error.


Any assistance with this would be appreciated. I am very happy that the program seems to work perfectly in POM and hope there is a solution or work-around for this error. I did not expect that I would be able to run this 64 bit windows program on an M1 Mac, so this was a nice surprise - well done POM team! 


Thank you,


Edité par gibbsjj

gibbsjj Mercredi 9 Mars 2022 à 16:48

Update: I ran POM from Terminal and selected the option to use a different version of Wine. When it comes to the screen to select the version of Wine, the only available option is 'System', and in Terminal I see this:


[POL_SetupWindow_checkbox_list] Message: checkbox_list answer: Use another version of Wine

find: /Users/myusername/Library/PlayOnMac//wine/darwin-x86/*: No such file or directory


I verified that the path does exist, but there is nothing in the darwin-x86 folder. OK, do I need to install a different version of Wine? As stated in my first post, the Windows program that I want to run does work using whatever the 'system' version of Wine is, but only during the install process. Once the install is complete, I get an error when trying to run it.


Here is another error ('Bad CPU type in executable') that might be the cause of my problem - this happens during the install of my program:


[POL_System_SetArch] Message: POL_ARCH set to x86on64

/Applications/ line 896: /Applications/ Bad CPU type in executable


And this:


[POL_Wine_PrefixCreate] Message: No version specified. Using system version ()

[POL_Wine_PrefixCreate] Message: Creating prefix ()...

[POL_Wine_PrefixCreate] Message: Setting WINEARCH to win64

/Applications/ line 964: /Applications/ Bad CPU type in executable


Now, with my program installed if I go to 'Configure' and then enter the 'wine versions manager' screen, there are no versions listed in either of the columns. Here is what I see in Terminal:



Traceback (most recent call last):

  File "urllib/request.pyc", line 1350, in do_open

  File "http/client.pyc", line 1240, in request

  File "http/client.pyc", line 1286, in _send_request

  File "http/client.pyc", line 1235, in endheaders

  File "http/client.pyc", line 1006, in _send_output

  File "http/client.pyc", line 946, in send

  File "http/client.pyc", line 1409, in connect

  File "ssl.pyc", line 500, in wrap_socket

  File "ssl.pyc", line 1040, in _create

  File "ssl.pyc", line 1309, in do_handshake

ssl.SSLCertVerificationError: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certificate (_ssl.c:1108)

During handling of the above exception, another exception occurred:

Traceback (most recent call last):

  File "/Applications/", line 24, in _sync_fetch_all_available_wine_versions

  File "urllib/request.pyc", line 222, in urlopen

  File "urllib/request.pyc", line 525, in open

  File "urllib/request.pyc", line 542, in _open

  File "urllib/request.pyc", line 502, in _call_chain

  File "urllib/request.pyc", line 1393, in https_open

  File "urllib/request.pyc", line 1353, in do_open

urllib.error.URLError: <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certificate (_ssl.c:1108)>


So, this might be a different problem but it looks like some kind of SSL cert problem is keeping POM from getting the list wine versions. I am able to open the URL just fine in a browser:


Next I will research if it is possible to manually install another version of wine and see if this can resolve my problem.


gibbsjj Mercredi 9 Mars 2022 à 17:55

After some reading and google searching, I figured out that this version of POM only supports the 'System' version of wine, which is 32-bit. Also the ability to install different versions of wine is broken. Hopefully this is fixed in a future release!

Edité par gibbsjj

Quentin PÂRIS Jeudi 17 Mars 2022 à 11:48
Quentin PÂRISAnonymous

macOS 10.15+ does not longer support 32bit.

Therefore, we are forced to execute a special wine version that runs 32bits program with 64bits wine binaries. Only few version support this

kenk Jeudi 16 Juin 2022 à 22:41

MacBook Pro, Apple M1 Pro

macOS Monterey 12.4 (21F79)


My reply is bit old, may be this will someone else.

I downloaded the 32 bit version of the installer. 

Thankfully Notepad++ people still makes both versions.

Then I installed it as a program that I downloaded and it worked.

This is the version I installed.

Another issue I noticed is that once installed, Notepad++ cannot see any files inside ~/Documents.

I even gave Full Disk Access in System Preferences > Security & Privacy > Privacy tab > Full Disk Access (on LHS list) > Add to the list off allowed apps using the plus button

In the end created my own ~/MyDocuments folder and using that for files I would edit with Notepad++

Also may be related to this:

Edité par kenk