Command & Conquer 3 v1.09

Menu is black or Cursor error

Auteur Réponses
deukalion Mercredi 15 Octobre 2008 à 20:34

This is my problem. I've installed Command & Conquer 3 with the POL scripts that are available in the program, it worked out good until the end when it says "unable to find 0.9.58-cnc3". I just copy the folder from $HOME/.PlayOnLinux/tmp to ~/WineVersions and it works. Problem here is that all the menus are text-less. If I change to my system version instead "1.16" the cursor problem occurs instead.

I've tried the git-cnc3 version from the other forums (which is a year old) and that version won't allow me to play fullscreen. It says it's 1920x1200 (my resolution) but it's a small window about 1024x768 instead, so I've struggled with that version too and given up. Cursor seemed to work there I recall.

I've tried winetricks with "env WINEPREFIX=" the cnc3 prefix and install all the fonts available from winetricks but they didn't do the tricks, and it would be odd if that's the problem cause 1.16 runs the game fine and the menus are visible. So it's not something I'm missing, just that there's something wrong with the 0.9.58-cnc3 version.

I've also patched the game but tried it without patching too, still the same error. No menus or the missing cursor thingy. While patching I've also used the "script" for 1.09, and done it without. No diffrence.

Any ideas? Couldn't find a search function on this forum so I couldn't find anything on this matter and if it's been a problem for others there might have been some changes done to the script.

Also, something to add here is I've tried my own compiling of Wine v1.11 with the cursor fix that is available from WineHQ, but that version just refuse to start if I put in the WineVersions directory.

Any ideas might be of intrest at this point. If these scripts don't work and the compability is 4 of 5 I expect a little more from this program that I've experienced. This is my first try and I like the idea of PlayOnLinux, don't want to throw it away because one game gets on my nerves.
Kjella Mercredi 15 Octobre 2008 à 21:23

I don't have this game myself, but the AppDB how-to links to a patched 1.1.6 version. Perhaps you should try that one?
deukalion Jeudi 16 Octobre 2008 à 12:13

I've installed it. But I had to install it as my "standard system" version of Wine or CNC3 would get the same errors, when I installed it to ./WineVersions/ it wasn't any diffrence from the 1.16 without the CNC3 hack. So, what I'd still like is able to have a version in my WineVersion folder that works all the time. But there seem to be no possible way for that.
GNU_Raziel Dimanche 19 Octobre 2008 à 10:56

try the updated installer, it may fix your problem

This site allows content generated by members, and we promptly remove any content that infringes copyright according to our Terms of Service. To report copyright infringement, please send a notice to