KOTOR installation

Auteur Réponses
Jump to the page: 1 - 2
maino82 Mercredi 21 Octobre 2009 à 16:45


I'm trying to install Knights of the Old Republic using the provided script and I'm running into some problems. The issue is that I am getting an "Error: 1.1.31 not found" message. When I first installed PlayOnLinux I did not have 1.1.31 installed, but I have since gone to the wine homepage, added the appropriate repositories and when I do:

$ wine --version

it says "wine-1.1.31", so I know that version 1.1.31 is now installed from the official wine repositories. As background, I'm running Ubuntu Linux 9.04, 64 bit version, with wine 1.1.31 and gnome desktop. Prior to this I was using the wine version out of the Ubuntu repositories (1.0.1 I believe). Any suggestions would be greatly appreciated. Thanks in advance!

EDIT: Oh, one more item... I just ran PlayOnLinux from the command line to see if there were any other errors and this was the output:

--2009-10-21 07:58:21--
Connecting to||:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 7120 (7.0K) [text/plain]Saving to: `/home/maino82/.PlayOnLinux/tmp/LIST'

100%[======================================>] 7,120 39.1K/s in 0.2s

2009-10-21 07:58:22 (39.1 KB/s) - `/home/maino82/.PlayOnLinux/tmp/LIST' saved [7120/7120]

python: can't open file '/usr/share/playonlinux/python/tools/': [Errno 2] No such file or directory

So it looks like it's looking for a python script that isn't there. Any suggestions on where I can get the script or how to edit the POL script file to correct the location?


Edité par maino82

NSLW Mercredi 21 Octobre 2009 à 18:04

Please reinstall playonlinux as it seems it wasn't installed correctly.
maino82 Mercredi 21 Octobre 2009 à 18:26

I went ahead and uninstalled and then reinstalled from the POL repositories (version 3.7) with no luck. I'm still getting the same error. I searched for "/usr/share/playonlinux/python/tools/" and couldn't find it on my computer. There is, however a "/usr/share/playonlinux/python/". Should the install script point there?
NSLW Mercredi 21 Octobre 2009 à 19:10

There is no in playonlinux. Please download generic package and run PlayOnLinux from it.
maino82 Mercredi 21 Octobre 2009 à 19:39

I went ahead and tried to use the generic tar.gz, but get the same results. I thought maybe it was a problem with having the .deb installed while also trying to use the .tar.gz, but I uninstalled the .deb version and the results are still the same. I successfully installed Jedi Academy and Morrowind prior to this, so I know the installation is working to some extent. Could it be an issue with the script?
NSLW Mercredi 21 Octobre 2009 à 19:56

Could it be an issue with the script?

Quote from maino82

Yes this was issue with the script (but with POL also). Installation script didn't check if user have Wine 1.1.31 before using it. Now if you run script Wine 1.1.31 should be installed automatically.
maino82 Mercredi 21 Octobre 2009 à 20:45

I guess that's why I'm a little confused. 1.1.31 is already installed as the system version already, so there should be no need to install it again in this instance, right?

wget --output-document="$REPERTOIRE/tmp/LIST"
xyz=`cat "$REPERTOIRE/tmp/LIST" | sed -e 's/\\.//g' | cut -d';' -f2 | sort -n | tail -n1`
echo "$(echo $xyz | cut -c1-1).$(echo $xyz | cut -c2-2).$(echo $xyz | cut -c3-4)"

POL_SetupWindow_install_wine "$CHOSENWINEVERSION"

I'm guessing these portions of the script are where I'm running into issues. Since I know the system version is already the latest (1.1.31) can I comment out this stuff and run the script like that, or will that mess up my installation?

By the way, thanks for your help and for being patient with me. It's greatly appreciated!
NSLW Mercredi 21 Octobre 2009 à 21:55

You can comment out this if you wish
POL_SetupWindow_install_wine "$CHOSENWINEVERSION"
and insert
POL doesn't detect what Wine version do you've got in your system. POL has own versions of Wine which are only in ~/.PlayOnLinux/WineVersions so they won't override your system Wine version. This versions aren't from the moon, they are compiled from source packages downloaded at
maino82 Jeudi 22 Octobre 2009 à 3:41

Thanks for the info. I've made a little headway, and have started hacking together a script from what was posted, but I'm trying to install the first KOTOR, and both this script:

and this script:

appear to be for KOTOR2, rather than KOTOR1. I'm assuming the process is the same for both, with some changes for downloading and applying the patch. I will post my progress as I get closer to a solution, but it's looking like commenting out those lines at least fixes that problem. Thanks again!
NSLW Jeudi 22 Octobre 2009 à 9:10

Again this is my fault. I corrected KOTOR2 and pasted it in KOTOR1, sorry for that. Now KOTOR1 script is in its place.
maino82 Vendredi 23 Octobre 2009 à 1:56

Awesome, thanks! Installed perfectly, but now I need to figure out why the game crashes... thanks for your help!
NSLW Vendredi 23 Octobre 2009 à 7:44

It may be that there is regression in wine. According to AppDB KOTOR works good on Wine 1.1.18 with KOTOR patched to 1.3. Try to download Wine 1.1.18 in Tools->Manage Wine versions and assign this version to KOTOR. Then you could download higher versions and inform me which is the highest version you managed to play.
maino82 Samedi 24 Octobre 2009 à 16:55

OK, keep in mind that I haven't had time to fully test this and play the game with these, so I'm not sure about other in-game problems, but these are the versions that start up the game successfully and let me create a character:

1.1.18 - works
1.1.19 - works
1.1.20 - works
1.1.21 - works

Also, I found that 1.1.31 works for me when I go into the wine configuration and emulate a desktop, but otherwise it crashes. 1.1.18-1.1.21 also give weird results sometimes when not emulated (flickering screen, buttons appear offscreen, etc), and work perfectly when they are emulated, so I think I'll try playing on 1.1.31 emulated and see what my results are with that.
NSLW Samedi 24 Octobre 2009 à 19:09

Wow, thanks for test reports. What is your graphic card and what are your drivers?
maino82 Dimanche 25 Octobre 2009 à 2:17

No problem, it's the least I can do for all your help.

I'm using an nVidia 9500GT running the default drivers available with Ubuntu 9.04, which currently is the 180.44 release. Please don't hesitate to let me know if there's more info you need or more testing I can do. I plan on installing KOTOR 2 sometime this week as well, so hopefully that will go well.

Once again, thanks for the help and thanks to you and all the script writers out there. You guys are all making running games on Linux become almost as easy as installing it in Windows!
NSLW Dimanche 25 Octobre 2009 à 9:04

Have you tried Wine 1.1.22-1.1.30? Do you disabled Compiz or Kwin because this may cause flickering screen?
maino82 Lundi 26 Octobre 2009 à 16:12

I will go back and try without Compiz enabled next week. I'm out of town this week, so I apologize, but I won't be able to get any more tests done before next week.

I haven't tried 1.1.22-1.1.30 yet, but that is also on my to-do list.
Paul Mallako Mardi 26 Janvier 2010 à 22:46
Paul MallakoAnonymous

wine 1.1.34 is working, but I've had to set wine to emulate a desktop (here I'm using 800x600, but haven't tested with other resolutions),

I think that it would be good to add a POL_SetupWindow_message at the end of the installation, informing this necessity, or enabling desktop emulation inside .pol script.

Fedora Core 10
GeForce 8600M GT/PCI/SSE2
Driver: akmod-nvidia from fedora repositories
cenleilen Mardi 6 September 2011 à 23:35

I hate to revive a dead thread, but I am having issues getting KoToR to run on my system. I am running Ubuntu 11.04 Natty Narwhal. 1.6Ghz AMD Turion processor with 1GB of RAM and nVidia geForce Go 7150 hardware, running driver release 173. The game installed perfectly thanks to the script that was provided with the game. The first issue I had was that PlayonLinux/Wine was stating that it could not find my optical drive. I then switched to a different version of Wine(1.1.21, which has worked according to maino82). The program no longer states it cannot find my optical drive, but instead crashes. Wine states the program crashes due to an internal error. Also, KoToR config states that my processor is not longer a 1.6Ghz but instead it is two 800Mhz processors. It also states that my video driver is out of date and requests to look online for the latest driver. I will admit that I am a new comer to Linux and am certainly not a computer genius. However, I do know my way around a bit and am posting this as a last resort before I give up on getting this excellent game to work.
Shadowvar8541 Dimanche 26 Février 2012 à 7:05

Wine version: 1.2.2
Distribution: Ubuntu
Distribution version: 10.04 LTS
Graphics card: ATI, Radeon RV380 (Radeon X600, 128 MB)
Graphics card driver: Unknown
POL Version: 4.0.14

Using the disc based install, the problem I have encountered is that the installer is asking me to insert the disc that contains the file. I've looked on all four discs and there is no file. The discs are extremely clean.

Computer is Pentium 4 3.60 GhZ with Hyperthreading, 2.0 GB of RAM.
Vous êtes ici: Index > PlayOnLinux > KOTOR installation