Unable to find the version: 1.1.36

Auteur Réponses
jflarm Dimanche 24 Janvier 2010 à 16:17

Hello, this is the story:

I have the original cd's for Diablo 2 (expansion pack and everything).

- I've installed the playonlinux repo for Ubuntu Karmic from your webpage.
- Installed the repo for wine "sudo add-apt-repository ppa:ubuntu-wine/ppa". The current wine version was 1.1.37.
- Since I thought this might be the problem, I uninstalled it and disabled the repo.
- I downloaded the 1.1.36 wine version from " "
- I tried to run the PlayOnLinux application again and tried to install Diablo 2, I got the same error.

Anyone knows what I am doing wrong or a work arround to make this work.

Thank you in advance...
NSLW Dimanche 24 Janvier 2010 à 16:33

Script didn't download 1.1.36. It's fixed now.
jflarm Dimanche 24 Janvier 2010 à 16:43

I downloaded the 1.1.36 version from the Tools menu, and now the install launched.
Now I am doing the install. mean that the playonlinux .deb package from your repo will now downlad the needed wine automaticly?

Thank you.
NSLW Dimanche 24 Janvier 2010 à 18:41

PlayOnLinux has its own Wine and it doesn't interfere with Wines from deb packages so you can have both independently.
jflarm Lundi 25 Janvier 2010 à 4:19

Hi again. The original problem is solved. Now I've got two issues:

First, when the script asks for the CD's, I have to wait about 10 seconds after the CD stops spinning to click "next". If I fail to do that, the script doesn't find the CD and will NOT find the CD, I have to cancel the script and start it again.

Second, after the CD's are recognized by the script. The wine starts the real install, but when the program asks for a new CD, it won't recognize that the CD is inside the tray.

I read somewhere here that you could make images and mount them in several directories. I could try that, but then it would not be a real situation for playonlinux.

Am I missing something? or is there any other test I could do?
NSLW Lundi 25 Janvier 2010 à 9:08

I don't know why your disc has to stop spinning. For the second problem: I also don't know what it's caused but I changed script a little bit so you can check it out. If it don't work then you may tray with ISO images.
jflarm Lundi 25 Janvier 2010 à 18:06

1.-About the CD spinning, it is a linux issue, the system didn't load the CD's content before I click NEXT, now I click on it after I see that the system has loaded the CD's contents.

2.-After the wine starts the installer, the installation process asks "Please insert the CD labelled "Play Disk"." But I can not unmount the "Install CD" because it is stuck by the installer script in ~/.PlayOnLinux/instal.

I still have not tried yet mounted images from the cd's.
NSLW Mardi 26 Janvier 2010 à 8:56

Can't you force unmount process? On Fedora 12 when I wan't to unmount busy CD then an dialog pops up and I can confirm that I want unmount CD.
jflarm Mercredi 27 Janvier 2010 à 5:02

The message pops, and nothing happens when I click on it to confirm, BUT I can press the Open/Close on the tray and the CD pops out, but the system doesn't seem to unload the CD. When I load the new CD, Nautilus still shows the previous CD and its contents, and shows the new CD but not its contents.