Problem running Warcraft 3

Auteur Réponses
Dani Mardi 6 Juillet 2010 à 21:47

Hello, I'm a complete noob to PlayOnLinux and a intermediate-noob to linux

- Name of the Distribution: Kubuntu 10.04
- Name of the software and it's version: PlayOnLinux 3.7.3; Wine 1.2-rc3-W3
- Your desktop: KDE
- Errors from the software. And if possible, tell when or/and when it happens:
The game installs without problems (installs wine 1.2-rc3-W3 automatically). When I try to run it nothing happens, and in the KDE terminal this appears:

PlayOnLinux v3.7.3

Checking python : [ Ok ]
No internet access
Running Warcraft III : Reign Of Chaos
wine: failed to initialize: /home/mulx/wb/version/1.2-rc3/wineversion/1.2-rc3/usr/lib/wine/ cannot open shared object file: No such file or directory
I don't have a "mulx" directory. The file does exists in my .PlayOnLinux folder.
Is there a way of redirecting the path properly?

I have a GeForce G 105M/PCI/SSE2

NSLW Mercredi 7 Juillet 2010 à 6:54

Please assign Wine 1.2-rc5 to Warcraft 3. Temporally patched Wine will be not available, that means won't be working.

BTW. Thanks for reporting that. The script is already fixed.
Dani Vendredi 9 Juillet 2010 à 21:21

Hello, and thank you for the promptly reply!
I upgraded PlayOnLinux to 3.7.6 and assigned Wine 1.2-rc5 to Warcraft 3. That solved the file problem, so I'm marking this as solved.
However I still can't get the game to run:

it seems like a problem that would also appear on windows, since my KDE terminal only shows
Checking python : [ Ok ]
Running Warcraft III : Reign Of Chaos

So i think maybe its a compatibility issue with my laptop?. I tried using the Advanced Wine Configuration pluggin to change the DirectDraw Renderer mode between opengl and gdi but the error persists.

Many thanks
(sorry if I should've created a new thread)
wer0ckz Vendredi 30 Juillet 2010 à 13:11

yeah i got the same problem man. please help us
wer0ckz Vendredi 30 Juillet 2010 à 13:11

yeah i got the same problem man. please help us
ise Lundi 10 Janvier 2011 à 10:27

I had this issue this weekend after I have installed Warcraft 3 the first time.
It helped to disable the intro movie with the second solution printed at the Warcraft 3 entry in the wine appdb:

If you don't want to play the campaign, but only want to start Warcraft III without a crash while playing the intro then you can simply mark the intro as seen:

1. Open regedit:
$ wine regedit
2. Navigate in regedit to HKEY_CURRENT_USER/Software/Blizzard/Warcraft III/
3. Create a key (folder) Misc in the Warcraft III key. You can do so by right clicking the key.
4. Create a DWORD value seenintromovie with the value 0x1


After add this to registry in the right wineprefix directory the game starts without any problems. Playing is fine, no problems so far.

Edité par ise