Script modification

Auteur Réponses
guybrush.d Vendredi 10 September 2010 à 23:50

Hi everybody,
i hope won't hurt nobody because my could be a stupid question but i often get this problem,
so i hope to solve it definitely, here we are:

Some time when i try to install a new application through the database menu (the available
application script), i get different errors, the main cause is because the script is written in a language different from mine or just because the developer has a different distro, so qhat i'd like to know how can i modify those script? I didn't find any of that on my pc, now i'm having the same problem with a game it doesn't find the cdrom, but the cdrom is in the drive because wine
works with it, so i need to modify the script! Because since i knew pol i don't use wine itself anymore! Pleaze light me on!!!;-)
GNU_Raziel Samedi 11 September 2010 à 0:51

Could you be more specific please ? Which scripts/applications are you talking about ?

For a new application, we will re-post soon an updated/clarified tutorial to make a clean and functionnal script

We first focus on bug fix/improvements :)
guybrush.d Samedi 11 September 2010 à 11:25

thanks for your reply, well at the moment i'm trying to install mass effect, but it happened also with others application so i use to install it manually, maybe i did not explain myself very well,
i would like to know if i can modify the scripts that pol gives you in the menu, i tried to copy the script from the web and install it with pol but the program said it isn't a valid pol application, i tried
to find the directory where the pol script are located but i didin't find them anywhere on my hard disk. Is possible to modify those script or they are on line and you cannot?
guybrush.d Samedi 11 September 2010 à 11:30

OK, i add some explanation, the script i'm talking about are the ones in the repository! So the question is how can i modify those script, aren't they copied locally?
guybrush.d Samedi 11 September 2010 à 23:19

Hi guys,
i made a step forward i installed the script creator plugin and i tested the script, the problem was
the capital letter for "Setup.exe", changing it to "setup.exe made the script go on, but it didn't install
anyway. Later i installed it directlly in wine, but i thin i messed up something with the prefix so now
i don't know if the dependencies are installed correctly, the games starts but is very slow and the mouse patch doesn't work, nobody know how to solve the script problem so i can install it in a protected wineprefix?
Ante Lundi 11 Octobre 2010 à 17:58

If you need to redo the script it is located in .PlayOnLinux under your home dir and is named install.

Know this, my friend - the evil that you move against is the dark lord of terror. -Deckard Cain