Forums

[TEST]Age of empire 2

Auteur Réponses
powerpicton Dimanche 30 September 2007 à 15:53
powerpictonAnonymous

ça marche, mais pas top...

install sans souci, juste une fenetre en arriere plan, faut faire à l'aveugle (touche entré)
installation du patch 2.0a pas de problème
je joue avec un nocd, mon cd original étant mort si quelqu'un a peut tester "normalemnt" ce serait bien...
graphisme pas top mais je pense que c'est du à la taille de mon écran en résolution 1280*1024 (4/3)...
j'ai émulé le pilote audio

Les polices du menu principale sont noir, pas très lisible mais bon...

un bug à la con, ne surtout pas cliquer sur la minimap, ça plante le jeu

testé avec wine 0.9.46

ma config :

acer aspire E380-JE7L
AMD athlon 64 4400+ *2
geforce 8800 GT
2 Go de Ram
ecran acer AL2051W 16/10 eme
powerpicton Dimanche 30 September 2007 à 15:57
powerpictonAnonymous

j'ai parlé trop vite, ça plante de toute façon au bout de quelques secondes, je cherche encore....

ma config :

acer aspire E380-JE7L
AMD athlon 64 4400+ *2
geforce 8800 GT
2 Go de Ram
ecran acer AL2051W 16/10 eme
powerpicton Dimanche 30 September 2007 à 16:06
powerpictonAnonymous

décidémment,je vais trop vite lol

c'est bon, mon no-cd était pourri....

bilan tout marche nikel, juste les polices du menu principal en noire....

ma config :

acer aspire E380-JE7L
AMD athlon 64 4400+ *2
geforce 8800 GT
2 Go de Ram
ecran acer AL2051W 16/10 eme
cgizmo Samedi 22 Décembre 2007 à 16:10
cgizmo

Bonjour,
Je met a jour ce test qui ne correspond pas du tout a ce que j'ai du faire ^^ !

Version de wine : 0.9.51
Distribution : Ubuntu 7.10
Info importante :

Le jeu ne marche pas sans no-cd...
Le jeu ne marche pas de suite, il faut faire ces étapes dans l'ordre :

* Installez AOE2 avec LiveInstall - Ne pas installer DirectPlay lorsque l'installeur le demande.
* Installez la mise a jour 2.0a.
* Téléchargez ces DLLs , et décompressez le tout dans le dossier system32 de AOE2. Ceci permet de jouer en multi.
* TRES IMPORTANT : Supprimer le fichier dpwsockx.dll de system32. Si vous ne le faites pas le jeu ne marchera pas!

POUR CONQUERORS

* Installez Conquerors avec LiveInstall
* Installez le patch 1.0c.

Autre bugs :

* Si vous avez un écran 16'9, lancez le jeu dans un virtual desktop.
* Les polices du menu sont noirs
* Le jeu rame, j'espère que vous avez un bon processeur !
* Le changement de résolution ne marche pas
* Cliquer sur la minimap ne cause pas de bugs (en tout cas je n'en ai pas encore eu)

Voila!

PS : Je n'ai pas tester le jeu en multi, mais il devrais marcher...
Aymeric P. Dimanche 6 Janvier 2008 à 18:47
Aymeric P.
Admin

Version de wine 0.9.52
Drivers graphique ATI 8.40.4, ATI Radeon 9600
Distribution : mélange Ubuntu Kubuntu Xubuntu Debian
Info : D'après wine appdb il faut un crack pour le jeu, a priori ce n'est plus vrai. J'ai réussi a le lancer et à commencer une partie.
Il faut simuler un bureau virtuel, sinon des messages pendant l'installation (Création du répertoire, Direct Play ...) ne se vois pas et le jeu semble bloquer

Je n'ai pas tester les parties en réseau.

Un p'tit script
#!/bin/bash
if [ "$PLAYONLINUX" = "" ]
then
exit 0
fi
source "$PLAYONLINUX/lib/sources"
cfg_check

#Presentation
presentation "Age Of Empires 2 : The Age of kings" "Microsoft Game" "http://www.microsoft.com" "MulX" "AOE2"

Ask_For_cdrom
Check_cdrom "aoesetup.exe"
mkdir -p $HOME/.PlayOnLinux/wineprefix/AOE2
cd $HOME/.PlayOnLinux/wineprefix/AOE2

select_prefixe "$(pwd)"
creer_prefixe

cd $WINEPREFIX/dosdevices
rm ./*
ln -s ../drive_c c:
ln -s / z:
ln -s "$CDROM" ./d:
echo "[HKEY_CURRENT_USER\Software\Wine\X11 Driver]" > $REPERTOIRE/tmp/DesktopRoot.reg
echo "\"Desktop\"=\"1024x768\"" >> $REPERTOIRE/tmp/DesktopRoot.reg
regedit $REPERTOIRE/tmp/DesktopRoot.reg
rm -f $REPERTOIRE/tmp/DesktopRoot.reg
cd "$CDROM"
wine ./aoesetup.exe
message "Cliquez sur Suivant uniquement quand l'installation sera finie" "Installation"

simuler_reboot

creer_lanceur "AOE2" "Program Files/Microsoft Games/Age of Empires II/" "empires2.exe" "AgeOfEmpires.xpm" "Age of Empires II"
exit


A la fin de l'installation, il ne faut pas lancer le jeu

Les screens :



Oui je sais, sur les 2 premiers screen on ne vois que le bureau virtuel, pas sur les autres ou on vois tout, je me suis faché avec Gimp entre temps ...

La page des tricheurs : http://www.gamekult.com/tout/jeux/fiches/J000000139_astuces.html

Remarque :
Defois le jeu ne démarre pas, il faut le relancer.
Le texte dans les menu est en noir (faut connaître un petit peu le jeu pour savoir où sont les boutons)
Il est préférable d'avoir plus que la configuration recommander pour jouer
Le jeu passe peut être en plein écran, mais je n'ai pas tester. Une chose est sur c'est que l'installer en plein écran c'est pas gagné


PS : Je testerais l'extension un peu plus tard (mais nouveau thread)

Edité par MulX


Former member.
powerpicton Mardi 8 Janvier 2008 à 14:12
powerpictonAnonymous

zarbi Étrange, j'ai pas fait autant de manip.....mais j'ai pas testé en réseau !

Edit zoloom : Merci

Edité par Zoloom


ma config :

acer aspire E380-JE7L
AMD athlon 64 4400+ *2
geforce 8800 GT
2 Go de Ram
ecran acer AL2051W 16/10 eme
naudar Mercredi 30 Janvier 2008 à 10:08
naudarAnonymous

Version de wine : 0.9.54
Distribution : Mandriva 2008 One
Carte graphique : ATI X1100

En effet, il n'y a plus de besoin du crack pour y jouer, et pour ma part je peux y jouer sans le bureau virtuel, le fonctionne bien en grand écran, il lague juste un peu mais c'est parfaitement jouable.
Toumeno Mercredi 30 Janvier 2008 à 18:08
Toumeno

Muix, il y a 2 fautes dans le message d'avertissement le bon c'est :

"Cliquez sur Suivant uniquement quand l'installation sera finie"


edit : et le nom du jeu c'est Age of Empires II, pas Age of Empire II

Edité par Toumeno

Aymeric P. Jeudi 31 Janvier 2008 à 18:49
Aymeric P.
Admin

c'est corrigé
Bon à priori le jeu fonctionne maintenant sans crack, je le posterais ce week end (je suis tellement saturer que j'ai plus le temps de rien faire là :'( ).

Former member.
Toumeno Vendredi 1 Février 2008 à 18:53
Toumeno

Le script marche nickel. Par contre dans le nom du script c'est "Age of Kings" et pas "Age of king"
... Oui je sais je suis maniaque :P

Et tu as raison de l'être

Edité par Zoloom

Aymeric P. Vendredi 1 Février 2008 à 20:44
Aymeric P.
Admin

Bon voilà, j'ai corriger et proposer le script (je sais j'ai les droits d'accepter aussi mais pas aujourd'hui), si tu as l'icône peut tu la poster pour que Tinou ou Goku l'envoi sur le site ?
je l'avais gardé puis je sais pas où elle est partie

Le nom de l'icône c'est : "AgeOfEmpires.xpm" (pour les admin surtout)

en attendant je vais faire une petite partie

Former member.
Toumeno Vendredi 1 Février 2008 à 21:26
Toumeno

MuIX, je t'ai envoyé l'icone par e-mail
Aymeric P. Vendredi 1 Février 2008 à 21:38
Aymeric P.
Admin

Yep, je l'ai mise dans un des dossiers de mon espace chez free : http://mulx.free.fr/KtXVZ21183/
Disponible en png & xpm

Former member.
Toumeno Vendredi 1 Février 2008 à 21:48
Toumeno

Au fait pour le bureau virtuel, tu peux utiliser la fonction :

Set_Desktop On 1024 768
mazert Lundi 1 September 2008 à 15:15
mazert

Salut a tous,

Pour en revenir au tutoriel de cgizmo, lorsque je veut installer le patch pour age of empires the age of kings, j'ai un message d'erreur qui me dit : "vous ne possedé pas la version commerciale de age of empires" alors que pourtant c'est le cd original, faut t'il l'executer dans un endroit spécifique ou autres ?

http://mazert.c.la - premier sur le web
Zoloom Lundi 1 September 2008 à 16:00
ZoloomAnonymous

Oui il faut que tu fasse :

Installer > Installer une application non supportée > Installation manuelle > Installation sur un préfixe déjà installé > Tu choisis le préfixe de Age of Empire II > tu choisis le patch > une fois installé surtout ne fait pas de raccourcis/lanceur (vu que c'est un patch).

Normalement ça devrait marcher.