no wine prefix

Auteur Réponses
paulwratt Lundi 21 Novembre 2011 à 12:07

I had the same problem about 6 months ago, but got no answers for it. (cant find the post) I think I know why it happens now, but have no way to fix it from here.

ran PlayOnLinux (PCLinuxOS repo has v4.0.12)
it does the "first time" setup
but when you try to install anything, there are no wine prefixes in the list

I tried editing via the "configure" button, nothing gets saved (parts of the interface disappears after start)

when I run "playonlinux" from the console I can see "configure" read fail, with this backtrace:

Traceback (most recent call last):
File "/usr/share/games/playonlinux/python/", line 438, in assign
File "/usr/share/games/playonlinux/python/lib/", line 60, in SetSettings
fichier = open(cfile,"r").readlines()
IOError: [Errno 2] No such file or directory: u'/home/burner/.PlayOnLinux//wineprefix/default/playonlinux.cfg'

why does "wineprefix/default/playonlinux.cfg" not get created?

same goes for "wineprefix/wine/playonlinux.cfg"

I think they will both work if I can place a "playonlinux.cfg" in those 2 dirs

where can I get a "playonlinux.cfg" from a clean install (no games, no apps, no nothing)?

paulwratt Mardi 22 Novembre 2011 à 17:40

hmm.. this seems to be 2 seperate issues

btw, manage wine versions does allow install ok

"install" still gives no wine prefix, but I have managed to get "new configuration" and that is able to use different wine version

I got this far by trashing my original .wine (500Mb of working apps) and .PlayOnLinux folders

This is more than silly considering they are both new installs

I also figure that "playonlinux.cfg" is not meant to be in "default", or "wine" again this seems a bit crazy, unless that cfg file also allows version changing...

Vous êtes ici: Index > PlayOnLinux > no wine prefix