PlayOnLinux Protocol assignment

Auteur Réponses
Drowz0r Mardi 15 Mai 2012 à 19:17

Hello there

I need to assign the PlayOnLinux protocol to PlayOnLinux. Can someone advise on how to do that?

( is where it was causing me some problems.


Ubuntu 16.04 LTS
8GiB RAM | Intel 3.20 Quad Core CPU
GeForce GTX 750 Ti/PCIe/SSE2 | Dual 4.3 (5:4 res) 19" screens
Drowz0r Mardi 15 Mai 2012 à 19:19

I understand another thread said I needed "gconf" installed, but I'm not sure what that is. I see a lot of applications called "gconf".

Ubuntu 16.04 LTS
8GiB RAM | Intel 3.20 Quad Core CPU
GeForce GTX 750 Ti/PCIe/SSE2 | Dual 4.3 (5:4 res) 19" screens
Quentin PÂRIS Mardi 15 Mai 2012 à 22:30
Quentin PÂRISAnonymous

gconftool-2 -s /desktop/gnome/url-handlers/playonlinux/command '/usr/bin/playonlinux %s' --type String
gconftool-2 -s /desktop/gnome/url-handlers/playonlinux/enabled --type Boolean true
Drowz0r Mardi 15 Mai 2012 à 22:47


Thanks for your reply. I typed those in but nothing happened. Tried restarting my browser and clicking it again but nothing.


Ubuntu 16.04 LTS
8GiB RAM | Intel 3.20 Quad Core CPU
GeForce GTX 750 Ti/PCIe/SSE2 | Dual 4.3 (5:4 res) 19" screens
swizzler Jeudi 19 Juillet 2012 à 21:21

Same here, the above fix did nothing, still refused to open file with error it was unrecognized. I've confirmed I've got gconftool-2 installed, confirmed there is a playonlinux file in /usr/bin/playonlinux, confirmed i've got the latest version of PoL, and quit out of X and restarted, still get an error clicking the url saying there's no program associated.

found a secondary fix here:

This sends the url to playonlinux, then playonlinux responds with error:

"There is nothing installed to run .php?id=236 files." (the end of url link to the file.)

I then tried copying the source code and saved it onto my computer and ran it as a local script. It complained that the script wasn't signed, because it's just a text file I grabbed off the net.

then after I told it to continue anyway it just closed and didn't run the script at all.

I would rather have another option in PlayOnLinux under the tools option that says something like "download a script via URL" it's simple, it works and it doesn't require buggy dependencies.

I appreciate what you guys have done for the linux gaming community, I'm hoping to be able to switch my main computer over to linux completely and this program is getting me close. thanks!

Edité par swizzler

Quentin PÂRIS Jeudi 19 Juillet 2012 à 23:47
Quentin PÂRISAnonymous

Does playonlinux http://url work? If not, it is a regresion of 4.1 version and I have to fix it

Edit: Oh yes I remember now. It is "playonlinux-url-handler" you should run!

Edité par Tinou

swizzler Vendredi 20 Juillet 2012 à 4:41

Ok I did what you said (btw its listed in the bianaries file as "playonlinux-url_handler" missed it several times.)

anyway I ran the command and here was the result:

$ /usr/share/playonlinux/playonlinux-url_handler "playonlinux://"
[main] Message: PlayOnLinux (4.1.3) is starting
[clean_tmp] Message: Cleaning temp directory
[POL_GPG_auth_script] Message: Checking signature of /home/sam/.PlayOnLinux//install
[POL_GPG_install_key] Message: Importing PlayOnLinux public key
[POL_Bash] Message: POL GPG : Good signature -
[POL_SetupWindow_Init] Message: Creating new window for pid 30532
Traceback (most recent call last):
  File "", line 85, in <module>
    app = PlayOnLinuxApp(redirect=False)
  File "/usr/lib64/python2.7/site-packages/wx-2.8-gtk2-unicode/wx/", line 7981, in __init__
  File "/usr/lib64/python2.7/site-packages/wx-2.8-gtk2-unicode/wx/", line 7555, in _BootstrapApp
    return _core_.PyApp__BootstrapApp(*args, **kwargs)
  File "", line 58, in OnInit
    self.frame = gui.POL_SetupFrame(os.environ["APPLICATION_TITLE"],str(pid_to_open),top,left,str(pid_to_open))
TypeError: __init__() takes exactly 7 arguments (6 given)
The command never popped anything up, tried running it with and without PoL running. It also never quit by itself, I let it run for several hours before Ctrl+C'ing it. Any ideas? Thx for the help btw.

Edité par swizzler

Quentin PÂRIS Vendredi 20 Juillet 2012 à 17:06
Quentin PÂRISAnonymous

It is a bug. I will fix it in 4.1.4
Quentin PÂRIS Samedi 21 Juillet 2012 à 20:05
Quentin PÂRISAnonymous

Ok, it should be fixed with PlayOnLinux 4.1.4 on GIT
lahtis Mercredi 20 Février 2013 à 20:40

gconftool-2 -s /desktop/gnome/url-handlers/playonlinux/command '/usr/bin/playonlinux %s' --type String
gconftool-2 -s /desktop/gnome/url-handlers/playonlinux/enabled --type Boolean true

add attributes to about:config firefox
network.protocol-handler.expose.playonlinux -> Value -> false

add a program playonlinux-url_handler

Edité par lahtis

Using Ubuntu 18.04.4 LTS and latest Playonlinux.
My scripts:
pfadfaog Mardi 26 Mars 2013 à 2:49


When posting steps, please spell out in more detail what we're supposed to do with the different pieces.  It took me much longer than it needed to for me to figure out what to do with what different programs in order to use your helpful info.  A little more info would've been hugely helpful to this Linux novice.

Thank you for your work.

Edité par pfadfaog

pfadfaog Mardi 26 Mars 2013 à 3:09

i have managed to solve problem

Edité par pfadfaog

grodius Jeudi 20 Mars 2014 à 14:54

Seems to be tough for anyone on these boards to post their solution clearly.

Open the terminal and run:


(whatever your patch url is)

Please note I already had gconftool-2 installed. You may need to download that.

josep_linux Mardi 20 Juin 2017 à 16:10

Please assist am having this error when i try to launch the application am running:


Opensuse Leap 42.2



Could not find any application or handler for playonlinux://