america's army 3 worked well

then i killed it

Auteur Réponses
BETLOG Lundi 4 Juin 2012 à 14:48

After playing the linux port of UT2004 recently, and being impressed with how well it ran, I installed America's Army 3 in steam via PlayOnLinux and it ran flawlessly.
My old account refused to log in so I made a new recruit of the same name and I did a bit of the basic training.
The M203/SAW/grenade training ran well. It was occasionally buggy in exactly the same way that I rember AA training being a bit buggy years ago, with servercommunication failures not allowing the qualification scores to getupdated, and sometimes I'd run out of ammo, or the qualification round would run a bit long even after it was clearly finished. But despite this it worked very well.

Then I foolishly went into the settings and fiddled with stuff that wasn't just the keyboard/mouse controls (which I had previously tweaked successfully).
After pushing the 'detect optimal settings' button in the graphics section the game froze.
For a while i wasn;t even ableto start AA3 from the steam menu, but after going into the games steam options and "verify integrity of game cache".. and ittelling me it would repair several files.. and then doing what looked like the MS DX redistributable, and PB install..i could start AA3
HOWEVER Since that time (fiddling the graphics) I can open steam, start AA3, click'personnel jacket' ...'view selected soldier' and examine my soldiers stats (all of which read as zero (despite showing somevalues last time I was looking), but when I try to continue training by pushing the fat button "begin training" ....
nothing happens.
I suspect the auto-detector pokedsomething like antialiasing... and it's written it to a config. Thus killing any visible screen. (becasue the correct executables *seem* to be running, even though they arent visible)

I'm seeing the majority of threads go unanswered, I guess many people solve their issue and don't report back. So this is a placeholder and google search result that will hopefully be useful if I solve it, or someone can help us all out.

Edité par BETLOG

BETLOG Lundi 4 Juin 2012 à 18:14

I have no idea why this suddenly started working again, but it did, and suddenly I noticed a whole bunch of hud elements and hint messages tha were previously absent.
I guess.
BETLOG Lundi 4 Juin 2012 à 18:21

So now I'll add some observations as I go through this process.
First up:

The SAW/302/grenade training is buggy. But it tends to self-correct if you are patient, and do what it tells you to after it says to. Not before.

The training is also a little ambiguous about some questions and their meaning. Saying yes or no to various menus that ask if you want to continue and seem similar can result in frustrating results. Either you get it right and just retry the qualification, or you don't and you end up starting the entire tedium of listenig to the drill sergeant again.. from teh beginning.

The grenade launcher has a sighting mechanism that you MUST be able to adjust. If at any time you accidentally or intentionally boud anyhting to your mouse scrollwheel you may have killed the ability to adjust this sight.
If you cant 1) select grenademode 2) zoom in and 3) scroll to adjust the sight's range... then you cant accurately fire grenades.
To keep it simple: don't bind anythng to mouse scroll wheel.

Make sure you do NOT have AA disabled in nvidia settings or your hud willnot appear in the test end of the medical training section. Yes I know your card may not be able to do AA in wine, and yes the game probably shows it as completely disabled. But if you don't have it set to 'application controlled' in nvidia-settings you will wonder what is happening when you suddenly can't see essential menus.
Yes really.

Each time you are required to bringup the HUD and select oneof the 4 actions you will notice  Symptoms under it. Make note of what symptom correspond tothe action the instructor has just told you about.
There will be a quiz later :)
 Knowing the symptom for each action is the key.

Edité par BETLOG

BETLOG Mardi 5 Juin 2012 à 10:28

In kubuntu It's useful to kill off the plasma-desktop before starting:
in a terminal or alt-f2...
kquitapp plasma-desktop
and to restart it when you are done with AA3

I found that unless I was running a windowed app, at 1440x900 (on my 1680x1050 screen) that I could not see any of the HUD elements that I mentioned missing in the medical section above. Similarly if any plasma application popped up a notification it would probably make the HUD elements vanish, and often allowed the mouse to stray outside the game window, making me lose control of the game.
With the AA3 window running at this resolution I centered it on the desktop, and pressed alt-F3, selected 'advanced->no border' and configured 'advanced ->special window settings:
position-force-120,84 (centered on the desktop)
size-remember-1440,900 (the entire window with no borders or frame)
fullscreen-force-no (using alt-enter loses the HUD, and sems to make alt get stuck on)
minimised-force-no (as above re:mouse straying outside the game)
keep above-force-yes (just for good measure)
and i plan to test:
desktop-force-all desktops
BETLOG Vendredi 8 Juin 2012 à 12:32

BTW: America's Army 2 : Overwatch works perfectly...but not using wine nor POL, but a native port.