Diablo 3 just won't run...

Pretty sure it's the 12.4 catalyst.

Auteur Réponses
staredit Mardi 12 Juin 2012 à 0:19

Still not a pro with linux so I can't get this running for the life of me...  I don't know why it's so hard to install one graphics driver :(  Tried a bunch of tutorials but couldn't get any of them to work.  I'm not sure if they just omit little steps that they assume people understand or what...


Guess I'm just going to have to go back to windows...  Since it's a driver issue I suppose I can't hope for any progress in the future either...


If anyone has a good idea on how to get D3 to work on a computer with AMD 5450 I'd love to hear it, but I've tried everything I could find so far to no avail.

aurelienbis Mardi 12 Juin 2012 à 21:48

Admin edit: PlayOnLinux team has not checked this. We won't be responsible if any problem occur.

That's the procedure I followed for updating graphic driver with catalyst 12.4.
(remind :
Ubuntu 12.04 32bits
ATI Radeon HD 5400

1) Make a copy of what's following, or print it. You may have problem after the first or second reboot.

2) Uninstall old driver throught System setting => Additional driver.

3) Uninstall old drivers using these commands :

1)Run each of these, one at the time, if getting any faults ignore it:

-sudo sh /usr/share/ati/
-sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*

2)Remove your xorg.conf file:

-sudo rm /etc/X11/xorg.conf

3) Re-install xorg:

-sudo apt-get install --reinstall libgl1-mesa-glx:i386 libgl1-mesa-glx:amd64 libgl1-mesa-dri:i386 libgl1-mesa-dri:amd64 xserver-xorg-core

4)Configure xorg:

-sudo dpkg-reconfigure xserver-xorg

5) Reboot:

-sudo reboot

I had a lot of errors, but just ignored them. At this point, after reboot, i could not access left or top toolbar. Only desktop and terminal, that's why i needed to make a copy before.

3) Install new driver (catalyst 12.4) :

sudo apt-get install build-essential cdbs dh-make dkms execstack dh-modaliases fakeroot

cd ~/; mkdir catalyst12.4; cd catalyst12.4/


chmod +x

./ --extract driver

cd driver/common/lib/modules/fglrx/build_mod/

wget -O fglrx.patch

patch -p1 < fglrx.patch

cd ~/catalyst12.4/driver/ (=> for me it was just ~/driver , then you'll maybe have to find your folder using ls command)

./ 8.961 --buildpkg Ubuntu/precise

sudo dpkg -i fglrx*.deb

sudo reboot

4) After this reboot, i had a black screen. Then i tape Alt+ctrl+F2, login and wrote startx. (it was maybe useless but i did it anyway xD)
One last sudo reboot.

Game was working after this.

Edité par Tinou

aurelienbis Mardi 12 Juin 2012 à 21:49

Is there an error while installing new driver ?