Auteur Réponses
diepfanne Mercredi 25 Juillet 2012 à 12:00

Hey there.

I am using POL v4.0.14. on Ubuntu 12.04 32Bit (also tried on LinuxMint 13 64Bit).

But always when i want to install Macigka with the Script. Some Errors appear (no error message?). It only says i could send a report.

At the end POL says it encoured a Problem and then it closes.

Wen i still try to start the game, the game says a problem appeared. nothing more. Then Wine says "intern error - false parameter".

This time on Ubuntu, POL also said that the MD5 Checksum dont match.

How can i fix this things?

petch Mercredi 25 Juillet 2012 à 17:44

First thing first, upgrade PlayOnLinux, latest version is 4.1.3.
Find how in the "Download" page on this site.
diepfanne Mercredi 25 Juillet 2012 à 21:26

On a complete new installed Ubuntu, with all updates, and the newest POL again the same Error: Wine seems to be broken.
When the program still works, ignore this message.

(i translated the error by myself. my POL is german, maybe the problem?)

But i can click next


Now there is the Error: You must first install .NET framework 3.0SP1 bevore installing or reparing the product.

Edité par diepfanne

petch Mercredi 25 Juillet 2012 à 21:46

The script seems to try to install .NET 3.5, so something must have gone wrong during installation.
Feel free to file a bug report (Tools > PlayOnLinux debugger, select install script and click on the "Report a problem" button).
diepfanne Mercredi 25 Juillet 2012 à 22:51

And then i have to wait until somebody fix the script?

petch Mercredi 25 Juillet 2012 à 23:08

The author maybe. I personally avoid modifying scripts I cannot test, for one.
stedevil Jeudi 26 Juillet 2012 à 10:25

I also have lots of problems with Magicka (v1.4.7) installed on POL (4.1.3), and yes, very likely one of the issues is the broken dotnet35 script. It just fails to cleanly install. Possibly there are other incompabilities as well, but passing the dotnet35 hurdle would be a required step forward in any case.

Manually, in another wineprefix, I have managed to use the latest Wine (1.5.9) (with it's autodownload of Mono) in combination with latest development winetricks ( to properly install dotnet35. But I have no clue of how to edit the POL script ( to exactly mimick how winetricks latest dev version does it.

Anybody that could lend a hand with that?

BTW why doesn't the POL scripts specify what version of the software that has been tested working? I found a source claiming ( that Magicka stopped working in wine after
In any case, that is a headache for after fixing dotnet35. :p

For the record, I'm on Ubuntu 12.04 using lates ppa for wine 1.5.9 and the winetricks way will get Magicka installed and even begin to start up (it crashes on the startup screen though, with a graphics driver error, but that might be a wine setting issue?).
"System.ArgumentOutOfRangeException: The render target index must be within the valid range for this device."

In any case, first step is to make POL dotnet35 working so POL Magicka installs correct so there is a chance it can work. :)

Edité par stedevil

stedevil Samedi 28 Juillet 2012 à 0:20

Submitted a bugreport. :)
stedevil Samedi 28 Juillet 2012 à 1:25

Meanwhile, if anyone has a clue about what could be the issue and what to do about it to make Magicka run for me, below is the errorlog Magicka spits out

The GFX hardware btw is an AMD/ATI Radeon 6770, using the latest official ubuntu catalyst drivers, so that the card wouldn't manage to run anthing a DX9 game would throw at it is highly unlikely.

(This is from the Demo, ie v1.4.0.0, but the exact same issue happens on fullversion v1.4.7.0)

Version:     Thread: RenderThread

System.ArgumentOutOfRangeException: The render target index must be within the valid range for this device.
Parameter name: renderTargetIndex
at Microsoft.Xna.Framework.Graphics.GraphicsDevice.SetAbstractRenderTarget(Int32 renderTargetIndex, RenderTarget renderTarget, CubeMapFace faceType)
at Microsoft.Xna.Framework.Graphics.GraphicsDevice.SetRenderTarget(Int32 renderTargetIndex, RenderTarget2D renderTarget)
at PolygonHead.ParticleEffects.ParticleSystem.UpdateParticles(Single iDeltaTime, Vector3& iRefPoint)
at PolygonHead.RenderManager.RenderScene(Scene currentScene, DataChannel iDataChannel, GameTime& iGameTime)
at Magicka.Game.Draw(GameTime gameTime)
at Microsoft.Xna.Framework.Game.DrawFrame()
at Microsoft.Xna.Framework.Game.Tick()
at Microsoft.Xna.Framework.Game.HostIdle(Object sender, EventArgs e)
at Microsoft.Xna.Framework.GameHost.OnIdle()
at Microsoft.Xna.Framework.WindowsGameHost.ApplicationIdle(Object sender, EventArgs e)
at System.Windows.Forms.Application.ThreadContext.System.Windows.Forms.UnsafeNativeMethods.IMsoComponent.FDoIdle(Int32 grfidlef)
at System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(Int32 dwComponentID, Int32 reason, Int32 pvLoopData)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Application.Run(Form mainForm)
at Microsoft.Xna.Framework.WindowsGameHost.Run()
at Microsoft.Xna.Framework.Game.Run()
at Magicka.Program.Main(String[] args)

0x00a9 Microsoft.Xna.Framework.dll->Microsoft.Xna.Framework.Graphics.GraphicsDevice.SetAbstractRenderTarget
0x0009 Microsoft.Xna.Framework.dll->Microsoft.Xna.Framework.Graphics.GraphicsDevice.SetRenderTarget
0x02c5 PolygonHead.dll->PolygonHead.ParticleEffects.ParticleSystem.UpdateParticles
0x0350 PolygonHead.dll->PolygonHead.RenderManager.RenderScene
0x00c2 Magicka.exe->Magicka.Game.Draw
0x009a Microsoft.Xna.Framework.Game.dll->Microsoft.Xna.Framework.Game.DrawFrame
0x02fc Microsoft.Xna.Framework.Game.dll->Microsoft.Xna.Framework.Game.Tick
0x0006 Microsoft.Xna.Framework.Game.dll->Microsoft.Xna.Framework.Game.HostIdle
0x0019 Microsoft.Xna.Framework.Game.dll->Microsoft.Xna.Framework.GameHost.OnIdle
0x0022 Microsoft.Xna.Framework.Game.dll->Microsoft.Xna.Framework.WindowsGameHost.ApplicationIdle
0x0008 System.Windows.Forms.dll->System.Windows.Forms.Application+ThreadContext.System.Windows.Forms.UnsafeNativeMethods.IMsoComponent.FDoIdle
0x01d2 System.Windows.Forms.dll->System.Windows.Forms.Application+ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop
0x01de System.Windows.Forms.dll->System.Windows.Forms.Application+ThreadContext.RunMessageLoopInner
0x0013 System.Windows.Forms.dll->System.Windows.Forms.Application+ThreadContext.RunMessageLoop
0x0011 System.Windows.Forms.dll->System.Windows.Forms.Application.Run
0x0024 Microsoft.Xna.Framework.Game.dll->Microsoft.Xna.Framework.WindowsGameHost.Run
0x00bf Microsoft.Xna.Framework.Game.dll->Microsoft.Xna.Framework.Game.Run
0x01c6 Magicka.exe->Magicka.Program.Main
Vous êtes ici: Index > PlayOnLinux > Macigka