Dead keys on MS Office 2010

Auteur Réponses
gugabfigueiredo Mercredi 17 Octobre 2012 à 16:44

Hi there.
Relatively new user writing here, so bear with me lack of knowledge.

So i have been using MS Office2010 on POL for a while now.
Out of the blue, when i turned my pc on this morning, i had some dead keys when trying to type on any of the MS Office apps.

More specifically these ones: |é| |è| |ã| |ç| |"| |`s|

They are somewhat important characters in Portuguese(Brazilian). And it`s quite a hassle to write without them.
I made no changes whatsoever to the system since last night, so this is puzzling to me.

I made a clean install of POL and then MS Office2010 from the cd. And so far it was working great.
gugabfigueiredo Vendredi 19 Octobre 2012 à 17:27

ust quick update about my sys and what actions i took so far

I use POL on my Ubuntu 12.10 Netbook - HP Mini 110-1100
with 1Gb memory, Intel Atom 1.60 GHz x2
Intel 945GMEx86/MMX/SSE2

I just upgraded to 12.10, but problem persisted.
so I tried to re-install Office 2010 to no avail. Dead keys are still dead.

This is quite irritating, i was so comfortable using Office2010.
And since this is the main purpose of this netbook, it's unusable right now.
gugabfigueiredo Dimanche 21 Octobre 2012 à 13:02

Thought it could be a problem with wine... so i downgraded wine to 1.4

still not working properly, dead keys remain dead

Also tried to do a re-install of POL, but that to was fruitless.
This is irritating as hell.... doesn't anyone have any idea??
gugabfigueiredo Lundi 22 Octobre 2012 à 21:14

I was able to restore normal settings.

Here is what I did.

Reinstalled ubuntu to reset all configurations.
Installed POL, updated that.
Installed Office2010 again.

Then, it was working like a charm!

Problem returned as soon as I installed Japanese language input method, through ibus.
I promptly tried shutting down input method switcher (IMS). This resolved the dead keys issue, but not quite. Now instead of dead keys, I had those missing characters auto-typing, i.e. they would be typed regardless of the letter i was trying to apply them on.
Like this: |´e| |´a| |´i| |^e| |,c| |~a| |~o| |`a|

Just had reboot to get the normal input on Office2010 again.

However, this means that whenever i want to switch between input methods i need to reboot to either get IMS working or shutting it down. This way, no further configuration is needed to get back to use Office2010 through WINE/POL normally, with proper keyboard layout and input.

I would like though, if it's possible, not to have to reboot every time.
So If any of you out there is able to provide me with a solution for this, i'd be very gratefull.
I'm posting this on both POL and WINE forums. Whichever helps first I'll update the other as soon as I can.
gugabfigueiredo Mercredi 24 Octobre 2012 à 3:03

So i have a workaround for this one.

Exit IMS (Input Method Switcher), i.e. open on unity dash and chose default.

Then restart X server. You can set up shortcut on Precise 12.04 by going to:
"Keyboard Layout > Options > Key sequence to kill X server > Ctrl + Alt + Backspace" and check the box there.

Not exactly what I was looking for. But I'll take it as a win.