Open a shell and wine version

Auteur Réponses
rollerpalmer Vendredi 14 Décembre 2012 à 6:31


I just tried to exec or install something via winetricks in "Miscellaneous>Open a shell"  offered in POL and get this result only if it's running the app; 

wine client error:0: version mismatch 433/431.Your wine binary was not upgraded correctly,or you have an older one somewhere in your PATH.Or maybe the wrong wineserver is still running?


For example; I'm running steam and I want to go to its drive and open a shell to run "wine Borderlands2.exe".

When I want to know the version of wine in the shell it always uses the "system" version (wine-1.4). No matter if POL drive uses an other different.

Also, I killed wineserver, if exists, before running the app by POL.

- Name of the distribution Kubuntu 12.04.1
- Name of the software: Wine-1.5.10, wine-1.5.9raw3, wine-1.4
- Desktop KDE 4.8.5 
-Computer configuration.

 AMD Phenom II X4 965 3.4Ghz
Gigabyte GTX 460 OC.
4 GB ddr2
Propietary Nvidia drivers 310


I tried in a Kubuntu laptop and in a Ubuntu virtual machine with the same results.

Thank you in advance for your assistance.

Edité par rollerpalmer

Quentin PÂRIS Vendredi 14 Décembre 2012 à 8:30
Quentin PÂRISAnonymous

Use POL_Wine instead of "wine"
rollerpalmer Vendredi 14 Décembre 2012 à 14:30

I get this kind of error in the shell but it seems to be normal:

PlayOnLinux: ~/.PlayOnLinux/wineprefix/steam2/drive_c > POL_Wine instead of "wine"
[POL_Wine] Message: Running wine-1.5.10 instead of wine (Working directory : /home/guille/.PlayOnLinux/wineprefix/steam2/drive_c)
[POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See
wine: cannot find L"C:\\\\windows\\\\system32\\\\instead.exe"
[POL_Wine] Error: Wine seems to have crashed

If your program is running, just ignore this message
[POL_SetupWindow_Init] Message: Creating new window for pid 30694
[POL_SetupWindow_Close] Message: Closing window for pid 30694
[POL_Wine] Message: Wine return: 2


At the end it's fixing my problem :D

I have an other question, was it using the system version of wine in older versions of POL? It used to work for me without "instead of" way but I have never known what version of wine it was using :P

Thank you so much!
Quentin PÂRIS Dimanche 16 Décembre 2012 à 15:19
Quentin PÂRISAnonymous


When I said "Use POL_Wine instead of wine", I did not ask you to type "Use POL_Wine instead of wine, but to replace wine by POL_Wine in your command ...

rollerpalmer Dimanche 23 Décembre 2012 à 2:10

Facepalm. Understood. Thank you again.