The forum

Metro: Last Light Crashes

Crashes after 5 minutes of play

Author Replies
wildcard Wednesday 11 September 2013 at 1:31
wildcardAnonymous

Hey all,

I'm on Ubuntu 12.04 64bit with Nvidia 319.32 drivers. I'm running Wine 1.6 inside of POL. Metro: Last Light is being played from Steam. The game launches and plays very well. Downside is that after 5 minutes of play, sometimes more, it will just crash and go into a zombie state. This is confirmed at wineHQ as a bug. Below is a link to comment #10 in the bug post with a patch that fixes this issue.


How can I get this compiled into Wine 1.6 so I can play the game? I'm new to this and now sure if I can do this on my own or where to ask. I thought I would ask as well as there might be another version of wine in POL that has this patch as it was seen in other games. I did a search of the forums around Metro Last Light or out of memory issues as per the bug. I know the game is slated for a Linux release late this year, but patience isn't there for me.

Any help and direction is welcomed. Thanks for reading too.

Edited by wildcard

petch Wednesday 11 September 2013 at 13:01
petch
Developer

Hi,

Create a feature request in the bug tracker for a new custom build of Wine.
That should include:
- Purpose of the build, some URL(s) where the patches are being discussed are welcome
- base Wine version to patch
- URLs to the patch(es), they can also be attached to the feature request

I hope I'm not missing anything important...

Example: http://www.playonmac.com/en/issue-3001.html
wildcard Wednesday 11 September 2013 at 16:55
wildcardAnonymous

Thanks Petch! I posted a feature request here. I appreciate the guidance and response.
booman Wednesday 11 September 2013 at 18:10
booman

I've seen memory issues with both Crysis and Crysis 2. PlayOnLinux Devs compiled Wine 1.6-rc4-d3d_doublebuffer and fixed the problem.

I would try that patched Wine and see if it works. I have Metro 2033 also and can test it too.

Also, if you click Configure in PlayOnLinux there are some Display options with buffering too.
Normally I use FBO, but there is backbuffer and pbuffer.
Those might make a difference or not help at all.

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
wildcard Wednesday 11 September 2013 at 18:30
wildcardAnonymous

I'll try that. I forgot to mention above that I'm using Wine 64. I will update my ticket to reflect this information.

I'll test that patched wine you mentioned booman, just need to move my install to a 32 bit  prefix. Thanks!

**edit
I as well as you, use fbo. No difference sadly.

Edited by wildcard

booman Wednesday 11 September 2013 at 18:32
booman

Yeah, definitely install in a 32-bit virtual drive.
The doublebuffer patch seems to help with memory leaks, but who knows if it will fix your problem. Pretty easy to find out though.
Keep us up-to-date

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
wildcard Wednesday 11 September 2013 at 19:03
wildcardAnonymous

Just tested the 1.6-rc4-d3d_doublebuffer in a 32 bit vitural drive on Ubuntu 12.04 with no changes. Game starts, plays, sound is good. Crashes after 5 minutes. First try was 5 minutes roughly, second was 7 roughly. FBO on the first time off the second.

It was worth the effort though, I now can use this patched wine for some other games.
booman Wednesday 11 September 2013 at 20:07
booman

Dang, ok... then its probably not a buffer issue.

Yeah, Wine manager is great for testing Wine's with any game.

† Booman †
Mint 19 64-bit | Nvidia 415.25 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained