The forum

GOG: Quest for Glory does not install to standard path

Author Replies
jandrewedens Wednesday 18 September 2013 at 4:11
jandrewedensAnonymous

Hello,
I'm running PlayOnLinux 4.0.14 on an Acer AspireOne with Ubuntu Studio 12.04.02 (I believe it is Xfce).  I recently purchased the Quest for Glory bundle from GOG and I went through the steps outlined on the documentation page of this website.  I downloaded the setup.exe file and selected it when prompted by the PlayOnLinux installation wizard, then it proceeded to "create virtual drive."  Then the setup manager of the game popped up and I went through its setup and just left the installation options at default.  When it finished installing, I was given the option to start playing one of the games.  I was eager to test it so I selected one and a white window popped up saying:
    
    [main] fatal game not installed in standard path

but then the game started anyway. I closed it as soon as I was able, and there was still a window from the PlayOnLinux setup wizard that also said

     [main] fatal game not installed in standard path

So I hit next in that window, and the next said errors while installing.  Game did not install correctly.  And there were no games in the applications list.

Any help would be greatly appreciated.  I've been using Ubuntu for almost 8 years now, but I've never had much luck with wine...  
I'm not sure if it needs a script to run properly or where I might find such a thing.

Thank you for your time.  I tried to be as explicit as possible, but if there is any info lacking, please let me know and I will do my best to comply.

jandrewedens Wednesday 18 September 2013 at 5:32
jandrewedensAnonymous

I forgot to mention something important...

As the game's installation manager was running, the playonlinux window said please wait while game is installed.  Then a window opens that is grey message window opens with no message, just 4 buttons:

Okay, Cancel, Abort, Retry and the rest is cut off

I clicked okay, assuming that it must have been normal message during the install.  The buttons did nothing.

The install progress bar from the game stopped moving 

I canceled the install after waiting about 5 min. with no progress.  
Then I attempted to reinstall and the results were as my previous post.

I apologize for leaving this out before.  
jandrewedens Wednesday 18 September 2013 at 5:40
jandrewedensAnonymous

Never mind problem solved! I used xkill to close the game's install manager and all of the games popped up on my games list, and they work!

I am very happy with PlayOnLinux!
petch Wednesday 18 September 2013 at 7:50
petch
Developer

Hi,
This happens with their installers v.2 when installation takes too long; Problem is, installation time depends on exact box used for installation.
I added the standard workaround (disabling their custom skin), so it shouldn't happen again.

(By the way PlayOnLinux 4.0.14 is outdated, see on the download page how to upgrade).

Edited by petch