The forum

World of Tanks did work fantastic-some things I did to make it work

But all of a sudden stopped working

Author Replies
lshantz Tuesday 4 March 2014 at 18:08

Hey guys,

I see that this seems to be a serious problem for some. I am happy to say that I have been playing it for over a month, relatively trouble free. Until last night. The only issue I have is the odd color glitch. A tank will be purple, or odd color, but other than that, the fps is acceptable (30-45ish).

I am running on a Macbook Pro Retina display. The latest OSX. I have found that you need smcFancontrol to keep it from overheating badly. Also I have found that you need gfxcardstatus. I have to force it to use Intel believe it or not. Nvidia drivers suck at this point. (I looked for newer drivers, but have been unsuccessful so far) Colors are terrible.

I've tried every wine graphics combo I can think of. I settled on:
GLSL support; enabled
Direct Draw Renderer: default
Video memory size; 2048
everything else default.

Now fast forward to last night. I had played for several hours, and all of a sudden it stopped working right. I killed it, and I could not get back in. On start up, it would go to the play window, but you could not click on Play. This morning it will hang at looking for updates. If you leave it for a long time it will crash. I rebooted windows from within the PlayonMac application. I did a repair virtual drive. The one thing I noticed on the windows reboot that sometimes it quits out, just leaving Xquartz running.

My question is, do you think this is a PlayonMac issue, or a WOT issue? I hate to delete everything and start all over, but I'm leaning towards it being a PlayonMac corruption issue. Just not that experienced with troubleshooting, since it has worked so well.
lshantz Tuesday 4 March 2014 at 18:11

Was hoping I could just edit the above.

OSX 10.9.1
Wine version 1.7.12
lshantz Tuesday 4 March 2014 at 18:14

What ever is happening seems to be getting worse, not better:

This program tried to use a DOMDocument object, but
libxml2 support was not present at compile time.
fixme:ole:CoCreateInstance no instance created for interface {00000000-0000-0000-c000-000000000046} of class {2933bf90-7b36-11d2-b20e-00c04f983e60}, hres is 0x80004001
lshantz Thursday 3 April 2014 at 4:02

Was looking for an update. Any word on the stability of WOT? I've been playing with it for a month now. It occasionally locks up. Pretty hard. Sometimes, the only way out is a hold down the power button. Not often though. My fps seems low though. 11-15fps. It used to be higher with Intel video. The GOOD news is, that since I updated the system to the latest updates, the color now is solid in both intel and Nvdia!

Over all, I give it a thumbs up. Hard to play at 11fps... I will poke around and see if I can find something to help.
lshantz Saturday 19 April 2014 at 2:24

I have been playing now for a couple of months on this Mac and I would say that with the new updates from Mac, the color gltiches are gone and it is fairly stable. About once in 10 games it would lock up tight. FPS, was kind of poor, but playable. As many of you know by now, 9.0 is out and this has caused some new issues. IF the FPS is real bad, make sure you are not in a "windowed" mode. This REALLY kills the fps. Also, there is a dynamic way to change the settings. It is right shift, +, -. Increase/decrease. I found for me that just getting out of windowed mode solved my issues.

There is one thing I'm seeing that is new. At the end of each battle, it abends and I'm back at my main screen. Looking for any ideas on what if anything to tweak. thanks.
lshantz Saturday 19 April 2014 at 3:51

I just ran debug and all I'm seeing is: wine: cannot find

The syntax is wrong for Dos/Windblows, but not sure if that is the problem or how to fix it if this is the issue. This is the last line when it abends.

AND... there is NO ctfmon.exe in the system32 directory. ??

Edited by lshantz