The forum

Diablo3 Splash screen weird and not launching game.

Author Replies
control Wednesday 9 April 2014 at 20:44

Hi i have installed and reinstalled diablo3 RoS with no issues, launcher works fine, however it's seems that one or several libraries are missing or faulty.

i run 64 bits xubuntu 13.10 on nvidia 660 ti on driver 331.67 (tried with prior driver version aswell) and kernel 3.11. also tried wine versions 1.5.5 diablo3 ver3, 1.7.15, 1.7.16. and i have ia32-libs installed (and reinstalled)

what happens is that when clikcing play on the launcher i see the splash screen looking weird. and then nothing happens and process halts/crashes.
other games in steam for example work well.

playonlinux debugger log gives nothing useful, but here is the D3Debug.txt

any thoughts or ideas on how to solve this would be appreciated, i played it the other day on kubuntu 13.04 without any problems. bo idea what differs in 13.10.


EDIT:: it's not so much that i wan't a direct answer, but rather if someone can help me find the problem. for example, how can i run it through terminal but still use playonlinux (as in not having to have a separate regular wine install) for more valuable output perhaps, and so on. ::

Edited by control

This site allows content generated by members, and we promptly remove any content that infringes copyright according to our Terms of Service. To report copyright infringement, please send a notice to