The forum

Diablo 3

Graphic Card issue

Author Replies
Cyan Monday 21 April 2014 at 19:48
CyanAnonymous

Hi


I've recently attempted to install Diablo 3
on a Linux Mint 16 x64 Cinnamon config.

Installation goes fine. Battle.net screen is okay.

But when I try to play, I'm getting a message :
"Impossible : your graphic card does not have required capabilities".

Note that this graphic card works fine with Diablo 3 on Windows.

Also, as suggested on Ubuntu Forum, I checked hardware acceleration, and it seems to work fine too :

/usr/lib/nux/unity_support_test -p

OpenGL vendor string:   X.Org
OpenGL renderer string: Gallium 0.4 on AMD RV670
OpenGL version string:  3.0 Mesa 9.2.1

Not software rendered:    yes
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       yes



So I don't know what to do next...
petch Tuesday 22 April 2014 at 0:23
petch
Developer

OpenGL renderer string: Gallium 0.4 on AMD RV670

Quote


Tried a proprietary driver for your hardware, if there's some?
You are here: Index > PlayOnLinux > Diablo 3