The forum

Hard drive activity makes game sound skip

Author Replies
Fryndr Tuesday 13 May 2014 at 7:54

I have successfully installed Star Trek Online using your Neverwinter Nights guide. Everything is well except for the above mentioned issue. It seems the hard drive reads a little bit every few seconds or so. When it does, the sound in STO skips and sometimes the game skips. My system is modest. A Dell Inspiron 570 with a nvidia 9800 GT 1024MB.

Ty for any insight.
petch Tuesday 13 May 2014 at 10:28

From what I've read 1GB ram is the minimum required for this game, that's most likely the problem, either because parts of the game/wine/pulseaudio (if your system uses pulseaudio) gets swapped at the wrong time, or not enough of the audio files is read ahead to avoid skips because the cache is heavily constrained.
So I could suggest:
- quit everything not needed while playing the game
- temporary disable pulseaudio
- the above two by running the game in a separate X server instance
- fiddle with swappiness parameter
- add ram
Fryndr Tuesday 13 May 2014 at 16:54

Ok the 1024MB is how much memory is on the video card. My sytsem has 8GB of RAM. I'll try the pulseaudio and see if it helps.
petch Tuesday 13 May 2014 at 17:24

I wish I had a modest system like that
Fryndr Tuesday 13 May 2014 at 18:21

Ok I disabled Pulseaudio but didn't seem to have an effect in STO. As I've been looking around, I've noticed that a lot of people think Pulseaudio is the devil. I've looked up ways to remove it and use ALSA instead but I'm afriad of breaking Linux Mint 16 Cinnamon. Any thoughts?
petch Wednesday 14 May 2014 at 0:56

Removing entirely is likely to be painful, as it's a dependency of a lot of packages
I did this in an older version of Ubuntu using an alternate set of packages not compiled against PulseAudio, but I don't know if anybody took the time to do this for Mint Cinnamon...
Anyway it seems it's not solving your issue
Not sure how to diagnose what's really going on, iotop, atop?