The forum

Installer crashes


Author Replies
shadizzle Sunday 13 July 2014 at 1:30

Edit: should probably mention this is my first attempt at anything like this. New to linux



ive been following this tutorial:

and I do ok up until the installing the .exe file after the base configuration of my virtual drive. I can select the .exe, and POL attempts to start,but immediately crashes out with a generic error message.  Looking at my debug file, I see it stops at:

[07/12/14 16:09:02] - Running wine-1.7.22 /home/rawr/Desktop/OriginSetup.exe (Working directory : /)
wine: Bad EXE format for Z:\home\rawr\Desktop\OriginSetup.exe.

and I can get no further than this. Ive gone and made sure that curl, and samba were installed.  Along with trying both 32 and 64 bit versions, all with the same result.  Along with 1.7.22, ive tried 1.7.18, and 1.7.13 as suggested in the yt video.  any help would be greatly appreciated. System information is on the bottom of this post. The kicker to this is, though it is mentioned that the "thin" client will not work, I was able to get a base installation working with it untill that errors and refers me to the standard orginsetup.exe (needed).

Full debugger:

x86_64 x86_64 GNU/Linux
> lsb_release -a
> wine --version
> Distribution
  Ubuntu 14.04 LTS
> glxinfo \| grep rendering
  direct rendering: Yes
> glxinfo \| grep renderer
      GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer, 
OpenGL renderer string: Gallium 0.4 on SVGA3D; build: RELEASE;  
> OpenGL libs (Direct rendering testing)

[07/12/14 16:08:19] - Running wine-1.7.22 cmd /c echo %ProgramFiles% (Working directory : /usr/share/playonlinux/python)
C:\Program Files

[07/12/14 16:08:23] - Running wine-1.7.22 winecfg (Working directory : /home/rawr/.PlayOnLinux/wineprefix/Test)
[07/12/14 16:09:02] - Running wine-1.7.22 /home/rawr/Desktop/OriginSetup.exe (Working directory : /)
wine: Bad EXE format for Z:\home\rawr\Desktop\OriginSetup.exe.



Ubuntu 14.04LTS 64bit

Wine: 1.7.22(currently) 1.7.18, 1.7.13

Desktop: Unity

Errors: above


CPU: i7-980x

Memory: 12GB DDR3-2000mhz

Mobo: EVGA X58 Classified 3

Video: MSI Radeon HD7950

HDD: 128GB Runcore SSD 

HDD RAID: 3x 640GB WD caviar black RAID 0


If I missed something, please let me know- THANK YOU in advanced. 

Edited by shadizzle

jre Thursday 24 July 2014 at 3:05

I had the same problems 2 weeks ago. I guess the download was somehow broken. Installation of Origin works perfectly now again.

For installing games you may have to patch Origin and perhaps even wine.

Edited by jre

SimCity 2013 winehq AppDB maintainer