The forum

League of Legends w/Catalyst driver?

Author Replies
xerion567 Thursday 17 July 2014 at 6:49



I'm trying to get League of Legends running on a new machine. The client/lobby program runs fine and I am able to log in. However the game program crashes before displaying the logo splash image if I use the fglrx drivers and the section of display where the logo would appear is locked (tried fglrx, fglrx-updates, and beta Catalyst drivers, with identical results). If I use the open-source Radeon drivers the game will start and display, but at 10 fps (completely unplayable), not to mention the system is very slow in general with this driver.

I have also tried Wine versions 1.7.19-LeagueOfLegends2, 1.7.18-LeagueOfLegends3, 1.7.22, and 1.7.17 with identical results. Also no luck with the the "/etc/hosts localhost" fix.

Thanks in advance for your help!


My System

AMD 'Kaveri' 7850 APU (w/Radeon R7 200 Series GPU)

Ubuntu Gnome 14.04

Error Output

fixme:ras:RasEnumConnectionsW (0x12e908,0xc4dd248,0x6305fe34),stub!
fixme:ras:RasEnumConnectionsW RAS support is not implemented! Configure program to use LAN connection/winsock instead!
fixme:ver:GetCurrentPackageId (0x33d7c4 (nil)): stub
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:advapi:RegisterTraceGuidsW (0xcded51, (nil), {f7b697a3-4db5-4d3b-be71-c4d284e6592f}, 7, 0x127b0b4, (null), (null), 0x1559e48): stub
fixme:process:GetNumaHighestNodeNumber (0x33b4e8): semi-stub
fixme:ver:GetCurrentPackageId (0x33efa8 (nil)): stub
fixme:win:EnumDisplayDevicesW ((null),0,0x33f7cc,0x00000000), stub!
fixme:win:EnumDisplayDevicesW (L"\\\\.\\DISPLAY1",0,0x33f484,0x00000000), stub!
fixme:msg:pack_message msg 14 (WM_ERASEBKGND) not supported yet
fixme:wbemprox:wbem_services_CreateInstanceEnum unsupported flags 0x00000030
fixme:wbemprox:enum_class_object_Next timeout not supported
fixme:ver:GetCurrentPackageId (0x33e14c (nil)): stub
fixme:win:EnumDisplayDevicesW ((null),0,0x45ad3d8,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x45ad1d8,0x00000000), stub!
fixme:ddraw:ddraw7_Initialize Ignoring guid {aeb2cdd4-6e41-43ea-941c-8361cc760781}.
err:ntdll:RtlpWaitForCriticalSection section 0x7dcf1398 "wined3d_main.c: wined3d_cs" wait timed out in thread 005f, blocked by 0067, retrying (60 sec)


confuz3d Friday 18 July 2014 at 23:09

I'm getting simillar results,

Wine 1.7.19-LeagueOfLegends2

Ubuntu Gnome 14.04

AMD Radeon HD6870 proprietary drivers

err:ntdll:RtlpWaitForCriticalSection section 0x7dcf1858 "wined3d_main.c: wined3d_cs" wait timed out in thread 0067, blocked by 0060, retrying (60 sec)

I also tried the other usual fixes, still stuck here.

Righteou5 Tuesday 22 July 2014 at 9:03

nepomuk Thursday 24 July 2014 at 17:12

Lol works fine for me. Ubuntu 14.04 AMD HD6850 latest beta driver.

Anyway i had to install a few libs to get it working... Error28 (i think that is his nick) posted how to fix it. Search for his thread. (Sorry i cant post the link, writing from my phone)


Edited by nepomuk