The forum

Dotnet finally installed! Game doesn't run.


Author Replies
afd_rulez Tuesday 22 July 2014 at 5:53


I've been trying to install .NET Framework for over a week. It was finally downloaded !! Woohoo!

Unfortunately, I stumbled upon another problem, which I can't even identify. The game (Magicka) just won't run.

I'm using PlayOnLinux 4.2.4, Wine 1.7.22, and Ubuntu 14.04.


I was trying to install .NET libraries in PoL by using Wine 1.5.18. On the internets, using Wine versions 1.5.12-1.5.20 was recommended as to solve previous problems in installing dotnet, and installing it successfully. It was also recommended on Booman's comprehensive guide on GamersOnLinux. I was constantly trying with Wine versions 1.5.18, and 1.5.20, they never worked.

When I finally tried it in other versions. Everything installed. I tried with Wine 1.7.22, 1.6.2, and System (found in PoL when creating virtual drive).

I checked the success of installation by:

1. Recieving "Wine Returns 0" in terminal

2. Configure-->Wine-->Wine Uninstaller(just to check) and see what the files installed are. Where I found [.NET Framework 2.0 SP2, .NET Framework 3.0 SP1, and .NET Framework 35]

When using 1.5 versions, the result of Wine Return would be 67, and in the Uninstaller I'd see [.NET Framework 2.0 SP1, .NET Framework 2.0 SP2, and .NET Framework 2.0] (it always quit when installing 3.0).

I don't know how this happened, since all other sites cited 1.5 versions to be better for dotnet (Maybe has to do with PoL compatability? I'm using PoL 4.2.4)

Problem Behavior:

I open Steam, all smoothly and everything, and get to the game. Magicka installs in 20 minutes (had to sit through multiple instillations), and then press PLAY.

The screen is still and nothing happens. I made a habit of watching the behaviour of top command in terminal to see what happens in the background. Everytime I hit play, Magicka.exe runs for 3 seconds (never gets to 4) before disappearing/quitting.

(Note: Before adjusting the Registery Editor HKEY_LOCAL_MACHINE/Software/Valve/Steam/Apps/42910/DotNet to 1, the game would show a loading window to load .NET Framework for the first time. The loading doesn't disppear.)

Also, on occasion, this window would pop up. Basically repeating the message: [The .NET Runtime Optimization Service is started and paused.] a number of times, before stopping and nothing happening.

The .NET Runtime Optimization Service is started and paused.

Any suggestions will be appreciated.

Also, since I'm a newbie (been using Linux for a month), please guide me to provide any more details that will you understand this problem.

Best Regards,


New to this, and Loving it.
booman Wednesday 23 July 2014 at 1:23

Those errors make me think that Steam is not recogizing that dotnet is installed.
Does a window pop up When you click Play that tries to install "depencencies" like Dot NET Framework?

Try fooling steam with this Registry hack

Configuring Registry
The only reason we are modifying the Registry is because Magicka will automatically try to install dotnet, xna and directx at first launch. It will hang every time. So this Registry fix will eliminate the problem.

Wine Tab
Click Registry Editor

  2. Maximize Software
  3. Maximize Valve
  4. Maximize Steam

Right Click Steamand select New Key
Name the key: Apps

Right Click Apps and select New Key
Name the Key: 42910

This is what the heiarchy should look like

Now we are going to create some new REG_DWORD
Right Click 42910
Click New
Click DWORD Value

Name this DWORD: DirectX

Double-Click it
Enter 1 in Value data
Click OK

Right Click 42910 again
Click New
Click DWORD Value

Name this DWORD: DotNet

Double-Click it
Enter 1 in Value data
Click OK

Right Click 42910 one last time
Click New
Click DWORD Value

Name this DWORD: xna

Double-Click it
Enter 1 in Value data
Click OK

† Booman †
Mint 21 64-bit | Nvidia 515| GeForce GTX 1650
Linux for Beginners | PlayOnLinux Guides | PlayOnLinux Explained
afd_rulez Wednesday 23 July 2014 at 2:19

After seeing your guide, I always follow that step :) It isn't the problem.

After diging throught the prefix for the game, I found some peculiar files.

In [.../drive_c/Program Files/Steam/SteamApps/common/Magicka] directory I found that the game would create a text file for the error everytime I run the game. The name of the file looks like this: errorReport_2014.07.23-12.11.09_(1).txt. With a date and time stamps. I opened it and found the following:

Version:    Thread: RenderThread

Microsoft.Xna.Framework.NoSuitableGraphicsDeviceException: Could not find a Direct3D device that supports the requested features.
   at Microsoft.Xna.Framework.GraphicsDeviceManager.FindBestPlatformDevice(Boolean anySuitableDevice)
   at Microsoft.Xna.Framework.GraphicsDeviceManager.FindBestDevice(Boolean anySuitableDevice)
   at Microsoft.Xna.Framework.GraphicsDeviceManager.ChangeDevice(Boolean forceCreate)
   at Microsoft.Xna.Framework.GraphicsDeviceManager.ApplyChanges()
   at Magicka.Game..ctor()
   at Magicka.Game.get_Instance()
   at Magicka.GlobalSettings..ctor()
   at Magicka.GlobalSettings.get_Instance()
   at Magicka.Program.Main(String[] args)

0x0051 Microsoft.Xna.Framework.Game.dll->Microsoft.Xna.Framework.GraphicsDeviceManager.FindBestPlatformDevice
0x0000 Microsoft.Xna.Framework.Game.dll->Microsoft.Xna.Framework.GraphicsDeviceManager.FindBestDevice
0x005f Microsoft.Xna.Framework.Game.dll->Microsoft.Xna.Framework.GraphicsDeviceManager.ChangeDevice
0x0018 Microsoft.Xna.Framework.Game.dll->Microsoft.Xna.Framework.GraphicsDeviceManager.ApplyChanges
0x01a2 Magicka.exe->Magicka.Game..ctor
0x0021 Magicka.exe->Magicka.Game.get_Instance
0x0089 Magicka.exe->Magicka.GlobalSettings..ctor
0x0021 Magicka.exe->Magicka.GlobalSettings.get_Instance
0x0171 Magicka.exe->Magicka.Program.Main

Apparently, Xna is causing the problem.. because of the video drive I guess.

Now, I'm looking to figure what the exact problem is, or try to update my driver. What do you think?

Edit: This is my video card and driver info:

       description: VGA compatible controller
       product: 2nd Generation Core Processor Family Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0


Edited by afd_rulez

New to this, and Loving it.
afd_rulez Wednesday 23 July 2014 at 5:40

Okay, so I finally updated my intel driver using Intel's intel-linux-graphics installer. I got these results:

Tried out the game.. Didn't work. Same problem, same .txt file created: "Couldn't find Direct3D device".

Now trying to find out my computers capabilities through:

If anyone's familiar with it. Seems promising..



New to this, and Loving it.