The forum

GW2 freeze upon hitting run with Wine 1.7.1

Author Replies
Tangboshi Saturday 13 December 2014 at 2:39

Hello all,

i would like to play GW2. Unfortunately, as soon as i hit run my computer freezes.


I went to Configure -> Wine -> Configure Wine -> Graphics

and activated virtual desktop and set my desired resolution.

I strongly recommend "window mode" (simply set a resolution lower than your current host system's res.)


My system specs/ settings used:

Ubuntu 14.04 LTS

Intel i7 3537U

nVidia GeForce GT 750M


PoL 4.4.2/ PoL 4.4.5

Wine 1.7.1

GLSL disabled, video memory: 4096(mb)


I tried the following other versions of Wine:

1.5.12 (runs, but bad performance ~15fps) 1.5.28 (freeze)


I also added the following registry keys:


../Direct3D/DirectDrawRenderer = opengl

../Direct3D/VideoMemorySize = 4096


Thanks in advance for any help

Edited by Tangboshi

booman Monday 15 December 2014 at 21:47

Thanks for posting your fix! Good job!

† Booman †
Mint 20.1 64-bit | Nvidia 460 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained