The forum

Lost cyrillic input in PoL

Author Replies
Harkonnen Monday 15 December 2014 at 19:44

There is something really weird happened to my PoL install - i lost an ability to input cyrillic characters in all apps run through PoL. To clarify - it worked just a month or two ago, i think on the same version of PoL and Wine, but to be sure i tried downgrading PoL - its didnt fixed the problem. Wine version is irrelevant - even if i set PoL to use system Wine i stiil cant input cyrillic, and cyrillic input works if i run system wine directly.

The only two things i can think of is that either there is something with my PoL configuration or a security update to some library in the last few month is causing this. Any ideas about how this can be fixed?

P.S. After some experimenting i found out that cyrillic input works if i start PoL with LC_ALL=ru_RU.UTF-8 but this have undesirable side effect of switching interface language. Interestingy LANG=ru_RU.UTF-8 doesnt work (interface switches to russian but cyrillic input doesnt work). Normally i have LANG set to en_US.UTF-8 and LC_ALL not set and cyrillic input in PoL worked just fine.



Edited by Harkonnen